Assets disappear in contents when zoom level is set on asset types

198
0
03-01-2024 06:45 AM
Status: Open
Labels (1)
BarbaraS
Occasional Contributor

We have the following case:

Esri recommends creating maps using subtype group layers to view utility network data in order to optimize performance for Utility Network layers in ArcGIS Pro: https://community.esri.com/t5/arcgis-utility-network-blog/best-practices-for-working-with-utility-ne...

Unfortunately, symbology scale dependencies will dynamically hide layers from the contents pane when layers are outside of the set display range (see example below).

As each subtype (asset group) almost always represents several asset types, and as these asset types often represent features in different voltage levels (high / medium / low) standard symbology setting is used to set different scales for the different asset types.

BarbaraS_1-1709303184621.png

BarbaraS_2-1709303184623.png

MV represents medium voltage asset types and LV represents low voltage asset types in the above example.

Hence, the map shows e.g. medium voltage at scales up to 1:50.000, whereas low voltage typically is not added before zoomed in beneath 1:3.000.

When an asset type due to the forementioned symbology settings on scale is not shown in the map, it is also not shown in the table of contents. Let’s say the map in zoomed to 1:30.000 (hence hiding low voltage asset types) and the user that want to search e.g. all low voltage potential transformers of a given type, they will have no chance of knowing – unless understanding the underlying data model in details – for which subtype group layer to open the table and set up the Select by Attributes query.

If the symbol was removed from the map but kept in the table of contents, the user would be helped much better.

----

I was in touch with Esri support and they confirmed that the behavior with layers greyed out in the map contents pane is expected behavior when scale dependencies are configured through the layer's symbology. They have suggested a workaround:

“In beyond” and “out beyond” approach to include asset type.

  1. Start with a blank map.
  2. Add your data as a Subtype Group Layer.
  3. From the contents pane, select the subtype layer > right click > symbology > primary symbology > from dropdown set to "unique values" > Change 'Field 1' = "asset type". (Repeat for other layers).
  4. (optional) Remove any unwanted subtype layers from Contents pane.
  5. Select asset type layer from Contents pane.
  6. Set “In beyond” and “out beyond” visibility range.
  7. Test Zoom in/out.

 

In conclusion, our suggestion for Esri is to have the option to lock layers in the contents pane while zooming in and out, no matter which scale range was set.