ArcGIS Pro: Enable "Add all values" to use format settings from "All Other Values" like ArcMap does.

1464
11
02-06-2020 02:25 PM
Status: Implemented
Labels (1)
DavidWheelock2
Occasional Contributor II

In ArcGIS Pro: Enable the legend creation tool "Add all values" to use the format settings from "All Other Values" like ArcMap does.

In ArcMap when creating a legend of Unique Values, you can first make basic settings in the All Other Values symbol.  If you then select Add All Values, ArcMap will apply basic settings, such as line-width, offset, etc to ALL of the newly created symbols for the legend.  The is a very powerful feature that makes it easy to create a legend with dozens or hundreds of symbols that would be impossible or cost-prohibitive to create if each symbol had to be modified individually.  This is one of the features that makes ArcMap truly a Pro product.

ArcGIS Pro(?) seems to not have this capability.  When you select Add All Values, it just creates the symbols with default settings of 1 point line width, normal position, etc.  This makes it difficult or impossible to created a legend of large numbers of symbols when they all have to modified individually.

Additionally, as mentioned in the comments below, More -> Format all symbols doesn't help with this because it only allows you to apply a small subset of format attributes to the group of symbols.

11 Comments
AndrewQuee

This does seem like a feature equivalency issue.  Is there a reason you can't use More -> Format all symbols after assigning unique values?  You can take off/modify outlines there if not needed, although I don't see way of universally applying an offset or decoration as you show in ArcMap.

DavidWheelock2

You answered your own question, Andrew.  Format all symbols only allows you to apply a tiny subset of the formatting characteristics the group of symbols.  That's why it doesn't work.

DavidWheelock2

Kory Kramer, are we going to classify this one as a bug, too?

ThomasColson

BUG-000108431 When formatting all symbols, the buttons to modify symbol layers and symbol structure are missing from the Symbology format pane when the feature layer uses graduated colors with more than one class

In Product Plan

might be related. 

EllenNodwell_IntegraShare

Definitely, the symbology takes a lot more steps - importing is possible, but initially, the steps to get symbols to be the desired ones takes some extra time. 

Recently, while fooling around with trying to get symbology sets for specific topic areas, not present in the "out-of-the-box" styles, I found this link https://esri-styles.maps.arcgis.com/home/index.html which has the links to downloads of sets of different symbol styles - and there are a number of them out there.

It was a search and discover exercise, but it is referenced in the Styles—ArcGIS Pro | Documentation on Styles... along with a bunch of other info.

Let's say that symbology in Pro is a whole new ball game - and on the flexibilty-complexity curve, it ranks high - high flexibility (does many things), but highly complex and complicated - as compared to ArcMap.

This involves a lot of learning and change.  Adding the functionality mentioned above would be great - could be good to really think through what the users do when symbolizing - and especially, changing from the tiny dot or plain polygon or line random selection color that they get initially when adding layers to their maps.

EdiePunt
Status changed to: Under Consideration
 
EdiePunt
Status changed to: In Product Plan
 
KoryKramer
Status changed to: Implemented

Implemented in ArcGIS Pro 2.8.

See Ideas in ArcGIS Pro 2.8 and (3:36) in the video.

DavidWheelock2

Delighted to see progress is being made on ArcMap equivalence and bringing powerful but overlooked features from ArcMap into Pro

I use ArcGIS Pro every day, for everything I can, and these catch-up features can't come fast enough.

One other thing.  I can't find any notification, either by e-mail or in Notifications, from when @KoryKramer announced the good news in his comment above on 5/13/21, so I only just noticed this today.  It appears that comments on an Idea in ArcGIS Ideas do not trigger a notification.

Can the ArcGIS Ideas be set to send a notification for a comment on an Idea?

KoryKramer

Hi @DavidWheelock2 

Glad you saw this update!  I'd say to check your notification settings and if you have specific questions, post to the https://community.esri.com/t5/community-feedback/bd-p/community-feedback board.

Thanks!