Apply Symbology From Layer Should Support Layers with Same Name

282
3
11-22-2021 08:53 AM
Status: Closed
Labels (1)
NathanHeickLACSD
Occasional Contributor III

I have three layers in a map that have the same name for certain reasons.  In the Apply Symbology From Layer tool, it clearly delineates the different layers in the map in the layer parameter pull-down menus by adding :n to the layer names.  However, it will not work if the input layer and symbology layer have the same name, even with the :n distinction.  It says they are basically the same.

I think this should work even the layer names are the same.  The layers are different and the operation makes sense.

Tags (1)
3 Comments
ABishop

The layers can be name the same as the source, but try renaming in the table of contents just to see if it will allow you to perform the distinguishing action.

NathanHeickLACSD

Hi Allison,

Yes, I tried renaming one of the layers and it validated easily and I ran the tool.  When I renamed it back, the error message came back.

KoryKramer
Status changed to: Closed

Thank you for posting this @NathanHeickLACSD We are tracking this as the following bug.

[BUG-000095736: Adding the same feature classes to the map twice with the same name returns the error, “ERROR 000400: Duplicate inputs are not allowed” when importing symbology from one feature to another.]

It was previously closed but after checking in with the geoprocessing team, we believe this is still a valid bug that needs to be addressed.  I just made some updates in the system so it may take a few days for those to get published, but for anybody affected by this bug, please visit https://support.esri.com/en/bugs/nimbus/QlVHLTAwMDA5NTczNg== and use the Subscribe button.  That will set you up to receive notifications and also increment the count of affected users which helps development teams prioritize work.

We apologize for the inconvenience.  The current workaround would be to do as stated - temporarily rename one of the layers, run the tool, and change the layer name back.