Event Editor: No linear referencing service error

192
7
Jump to solution
09-22-2020 07:58 AM
New Contributor III

I'm unable to build a working Event Editor application. After logging in, I'm getting the following error:

I'm attempting to follow the sparse and possibly outdated instructions here. Clearly, I've missed something important in the configuration and I'm looking for ideas.

The error seems to be saying that the app was unable to find an LRS network to work with.  I've confirmed that the service it's configured to use has an LRS network that I can manipulate with ArcGIS Pro. 

I've created and published a map that includes the LRS Engineering Network along with it's related features, including Redline.  I confirmed that M and Z are disabled in the Redline. Feature editing is enabled.

Fortunately, the server I'm using had a pre-installed Event Editor application because I was unable to find the download using the instructions Event Editor Deployment Guide.  I could not find an Event Editor listed in My Organization -> Downloads.

I'm attaching the config.json file. Here's how I filled in the values mentioned in the config guide:

  1. webmap: Set to the ID of the map web map created and published for event editing, obtained from the Portal
  2. portalAppID: Set the the ID for the Event Server application registered with the Portal 
  3.  portalURL: Set to the ArcGIS portal on the same server
  4.  geometryServiceUrl: Set to a local geometry server
  5. allowReconcileAndPost: true
  6. allowChangeVersions: true
  7. allowCreateVersions: true
  8. allowDeleteVersions: true

The login works file, which I think means the portalAppID and portalURL are OK. I think the issue must be with the services in the published webmap.  

I've checked repeatedly, the map has an LRS network:

I'm attaching the config.json file, in case someone can see the mistake.

Reply
0 Kudos
1 Solution

Accepted Solutions
Esri Contributor

Michael Nigbor‌  Another point to verify: when creating the webmap for Event Editor - the Map Service should be added not the Feature Service. This is a common misstep and causes confusion.

Ayan Palit | Principal Consultant Esri

View solution in original post

7 Replies
Esri Contributor

Michael Nigbor An area to verify is if Linear Referencing capability is enabled per documentation in link below.

Enabling the linear referencing capability—ArcGIS Pipeline Referencing Server | Documentation for Ar...  

Ayan Palit | Principal Consultant Esri
Reply
0 Kudos
New Contributor III

Confirmed.  It's enabled.

Reply
0 Kudos
New Contributor III

Do you need to restart the Event Editor when you make changes to config.json?  

Reply
0 Kudos
Esri Contributor

After making changes to config.json, admin should delete cache and reload the Event Editor web app.

Ayan Palit | Principal Consultant Esri
Reply
0 Kudos
New Contributor III

I recycled the application pool, which should clear the cache and reload the web application and will do this whenever I make a change to config.json going forward.

Unfortunately, that didn't change anything. I'm still getting the same error.

Does the Event Editor write a log file anywhere?  If so, maybe it will hold some clues

I appreciate the quick response.  Thanks.

Reply
0 Kudos
Esri Contributor

Michael Nigbor‌  Another point to verify: when creating the webmap for Event Editor - the Map Service should be added not the Feature Service. This is a common misstep and causes confusion.

Ayan Palit | Principal Consultant Esri

View solution in original post

New Contributor III

That was the trick! I used the feature service, instead of the map service.  Now my Event Editor is working.

Is there any way you can bold the "map service" or add a caution note on the Authoring a web map for Event Viewer page?

Whenever there is editing, I automatically assume feature services should be used. Using the map service for an editing application seems counter-intuitive.

Thanks Ayan Palit for the quick and accurate answer.

Reply
0 Kudos