Why does shape area/length fields get changed for local copy editing of feature layer?

457
2
07-03-2019 11:02 AM
RobCahalan
New Contributor III

I am using ArcMap 10.5.1 and ArcGIS Online. I have published a layer in ArcMap to a hosted feature layer with feature access. Once published, the feature layer setting show that edit and sync are enabled. When the feature layer is brought into ArcMap and I "Create a copy for local editing," additional Shape_Length/Area fields are created which precludes me from editing feature geometries. I do not have this issue when trying to edit in ArcGIS Pro, but I have some end users making edits that do not use Pro yet. When I try to cut a feature in ArcMap I receive the following error:

I have traced the issue back to the Shape attributes.

The SHAPE_Length/Area fields look like this in the original file geodatabase (notice SHAPE is all caps):

The Shape_Length/Area fields look like this in the hosted feature service (notice no caps and double underscore):

The Shape_Length/Area field look like this in the local copy:

If the Shape__Area and Shape__Length fields are deleted in the local copy, the geometry is able to be edited and synced back to AGOL.

Is there a problem in the way that I am publishing the data that is causing the issues with the Shape fields? 

Reply
0 Kudos
2 Replies
JacobHorstkamp
New Contributor

Have you figured this out? I'm having a similar issue.

Reply
0 Kudos
RobCahalan
New Contributor III

I have not...at this point I am typically doing edits in ArcMap...

Reply
0 Kudos