Vector Tile Layers and Querying

2259
5
Jump to solution
11-10-2016 11:00 AM
deleted-user-wgzH2d-p_0_f
New Contributor III

Anyone know when the capability to query vector tile layers might become available?  Right now I'm using a feature layer with no symbology over top of a vector tile layer to get querying capabilities, but it's very messy in the TOC and hard for users who don't have a GIS background (because they have to toggle on two different layers...).

Or...any other options?

1 Solution

Accepted Solutions
KellyGerrow
Esri Frequent Contributor

Hi Annina,

This functionality isn't available yet. I would like to encourage you to log an ArcGIS Ideas‌ about this as well as contact Esri Technical Support‌. There is a product enhancement that has been submitted and I would encourage you to ask to be attached so that you can be kept up to date on the status of the issue: ENH-000095476

-Kelly

View solution in original post

5 Replies
KellyGerrow
Esri Frequent Contributor

Hi Annina,

This functionality isn't available yet. I would like to encourage you to log an ArcGIS Ideas‌ about this as well as contact Esri Technical Support‌. There is a product enhancement that has been submitted and I would encourage you to ask to be attached so that you can be kept up to date on the status of the issue: ENH-000095476

-Kelly

View solution in original post

Matthew_Williams
New Contributor III

Has there been any changes/updates to this since 2016?

dmarkbreiter
New Contributor II

I'm also quite curious @Matthew_Williams  @KellyGerrow 

0 Kudos
SimonColeman1
New Contributor II

me too!

Tags (1)
0 Kudos
ahargreaves_FW
New Contributor II

Me too. I've followed the directions in this article that states if you choose the option to cache online or on the server:

"A vector tile layer is shared with an associated feature layer. The feature layer supports editing, querying features outside the current view, and richer statistics."

I've since cached a layer online. It did indeed generate an associated Feature Service and via the settings for the AGOL item I am able to "Configure Attributes: Select the attributes to include in the vector tiles". 

Sadly however now that cache has rebuilt itself I still get no access to attributes. What am I doing wrong here @KellyGerrow ?

ahargreaves_FW_1-1629929082816.png

This enhancement request was originally asked for in 2016! https://my.esri.com/#/support/bugs/ENH-000095476

0 Kudos