Unexpected "These layers did not draw correctly" notification

640
5
02-13-2018 03:48 AM
DavidMorgan2
New Contributor

A Number of my users have reported seeing the "These layers did not draw completely. There may be too many features to display. Try zooming in to a smaller area." notification over the last couple of weeks - this is occurring on newly created layers (with no features!) and older layers with small numbers of features (less than 100). 

The features attributes can be viewed in the table, but are not visible on the map.

Any suggestions of the reasons behind this and how to solve would be much appreciated.

A map experiencing this problem is shared here.... http://arcg.is/jSbbC 

5 Replies
XanderBakker
Esri Esteemed Contributor

I had several messages of layers that could not be added to the map, but I do see what you mean:

Please remove the editing capabilities from your layers, since any person at this moment can modify your data.

It might be good to report this to Esri Support and have them look at it. Are the geometries very complex (many vertices)?  CC KGerrow-esristaff

DavidMorgan2
New Contributor

Geometries very simple - points layers

0 Kudos
XanderBakker
Esri Esteemed Contributor

So, the number of vertices will not be the problem...

0 Kudos
KatieCullen
Regular Contributor II

How many points?

0 Kudos
KellyGerrow
Esri Frequent Contributor

Hello,

There is also a bug where this error message is displayed at incorrect times when there is an issue with the query to the feature service. This issue is scheduled to be fixed in the next update of ArcGIS Online.

There are a few workarounds posted in this post, How can a layer with no features have too many to draw?

To verify that you are running into the specific bug please get in touch with technical support or try one of the workarounds to see if it will resolve the issue for the time being.

-Kelly