Unable to Public Share Instant Web App

1092
5
03-02-2022 03:38 PM
10KYIGIS
New Contributor II

Hi there,

I've been really struggling with a web app that I intend to share for public access. It has two hosted layer views (both shared publicly) and the default Esri Imagery with Labels Basemap on a New Map Viewer Web Map (also shared with public):

This is the link to the web app:  

https://10kyi.maps.arcgis.com/apps/instant/sidebar/index.html?appid=83ddd0a2016241b69d8b377fa79b5f87

I have disabled Anonymous access to our organization, and I thought replacing the head of the url with https://www.arcgis.com would fix it as referenced in this article but it still prompts a user for a general ArcGIS Online log-in:

https://www.arcgis.com/apps/instant/sidebar/index.html?appid=83ddd0a2016241b69d8b377fa79b5f87

I've looked through what I can so far on multiple browsers (except for exporting a log from developer tools) and I don't believe I am using any Subscriber content that would be locking anyone out.

I've looked online for fixes, and none of the below seemed to help:

Solved: Making a web-app public - Esri Community

Solved: Cannot share content publicly - Esri Community

Solved: Arcgis Online Web app public access, asking for lo... - Esri Community

Anybody have any troubleshooting thoughts? Things I should try?

Thanks!

0 Kudos
5 Replies
jcbuckleyjr
New Contributor II

Were you ever able to resolve this issue?

I'm having the same trouble. I've copied a Survey123 stakeholder feature layer that I do not own, and I think my problem lies there. I don't want to mess with the owner's stakeholder layer; just wanted to copy it, and share it. 

I know my reply isn't helpful to solving your problem, so I apologize. Just commiserating. 🙂

However, you provided several links I will follow- thank you!

0 Kudos
AlexManikas
New Contributor

I have been dealing with this issue as well. I believe it has something to do with app builder itself. The moment I switched the web map from instant app to web app builder it did not prompt me to login. Can anyone else attest to this?

0 Kudos
JarrettLivesey
New Contributor II

Hello all I too am having this issue trying to access an Instant App where everything is shared publicly but the app requires a Login when I load it.  The App does this weird thing where it starts to show content on initial load, then the login screen pops up. 

Here is the link to my 'Public' Instant App:

https://daanmatch.maps.arcgis.com/apps/instant/nearby/index.html?appid=5ca5682dde954bf4abf92fdb7b8f8...

Any help from ESRSI would be very much appreciated !!  Thanks, 

Jarrett

0 Kudos
bcordola
New Contributor

Hi Jarrett, did you find a fix for this? I am still having the same issue. Everything is shared publicly, and the app initially loads, but then closes out and prompts the user to sign into my organization.

Any tips would be appreciated!

DerekMStrout
Occasional Contributor

Hi everyone,

In hopes that this might help someone, I just unexpectedly ran into this issue with an Insets app our team has developed in AGO.

Long story short, after confirming many times that all items (including an image I placed in the splash screen) were shared to the public, I discovered that I was still referencing an org-only layer in the Search settings of the app. Once I replaced that Search source with one using a public layer in the map, the log-in prompts stopped. Interestingly, this Search source persists in the app even after the layer has been removed from the web map. I'm assuming this is because you can add a Search source by URL, so it is still just looking at the AGO item URL. I did not test what would happen if you deleted that item from AGO entirely (if it would still be listed as a Search source in the app).

Cheers,
Derek