Unable to hide fields in attribute table in Map Viewer.

287
3
09-25-2023 03:28 PM
Labels (2)
LayerItOn
New Contributor III

I am trying to hide fields in a layer's attribute table in the new map viewer table but it is not saving. I have tried to hide in the attribute table settings, in the visualization tab of a feature layer, and tried editing the pop-ups but it does not stick even after saving. I have tried to open the feature layer in ArcGIS Pro and in the fields view hide the fields and then saving, but still nothing.

The map layers were created using Field Maps. I can clean up the pop-ups, but not the table in the resulting map. 

Thank you in advance! 

3 Replies
David_McRitchie
Esri Contributor

Hey,

I would test uploading a new copy of the layer and checking if you can hide fields on this.

I would also check to see if you can generate a View layer with the fields you want hidden excluded from the layer.

This should help let us know if this is data specific or not.

Many thanks,

David

 

Esri UK -Technical Support Analyst
0 Kudos
shapirot
New Contributor III

This can be done with a view, but shouldn't need to.  If it works in the view settings, what does that mean about the data that is preventing the table field settings from saving in the visualization tab for the data source?

0 Kudos
shapirot
New Contributor III

Did you ever figure out what was causing this?  I am running into the same issue currently