Unable to edit secured feature services

2765
3
Jump to solution
07-24-2014 05:59 AM
KendellRyan
Occasional Contributor

I have read several posts related to this, but I have not found one (yet) with a specific answer that fits our scenario.  I am using a secured service that sits on an internal server.  I can add the feature service, but editing is disabled (error message). In other posts, I read a little about the CORS stuff, but we are using 10.2 Server and the most up to date browsers (tried all 3).  So I thought that would not be an issue.  We have also disabled the option to "only allow SSL connections" in our AGOLO organization settings but that made no difference. 

FYI, I add the service using https://<xxxxx>/securearcgis/rest/services/

Thanks. 

0 Kudos
1 Solution

Accepted Solutions
MikeMinami
Esri Notable Contributor

Here are some troubleshooting tips:

  • You must be running ArcGIS Server 10 SP1 or greater. (which you are)
  • Must be using ArcGIS Server Authentication, which is token based. No web server authentication.
  • When connecting to your service, ArcGIS.com tries to get a token to use the service. Check that the token service is visible externally. Use this URL to get info about the ArcGIS Server:

http://<server>/ArcGIS/rest/info

Look at the setting for Token Service URL. If this URL is not externally accessible, then ArcGIS.com won’t be able to get a token. You need to edit the web.config files, located here for IIS.

C:\inetpub\wwwroot\ArcGIS\rest\web.config
C:\inetpub\wwwroot\ArcGIS\Tokens\web.config

  • If the Token Service is accessible, see if you can generate a token.

          https://<server>/ArcGIS/Tokens/gettoken.html

If you can generate a token, but it still doesn’t work, check the error message from ArcGIS.com (use the browser developer tools to track requests). If you get a http status 500 error, it may mean that our servers do not trust the certificate given by this Url. This sometimes happens when SSL providers change their root certificates and we don’t have the most recent ones. No self signed certificates.

View solution in original post

0 Kudos
3 Replies
MikeMinami
Esri Notable Contributor

Here are some troubleshooting tips:

  • You must be running ArcGIS Server 10 SP1 or greater. (which you are)
  • Must be using ArcGIS Server Authentication, which is token based. No web server authentication.
  • When connecting to your service, ArcGIS.com tries to get a token to use the service. Check that the token service is visible externally. Use this URL to get info about the ArcGIS Server:

http://<server>/ArcGIS/rest/info

Look at the setting for Token Service URL. If this URL is not externally accessible, then ArcGIS.com won’t be able to get a token. You need to edit the web.config files, located here for IIS.

C:\inetpub\wwwroot\ArcGIS\rest\web.config
C:\inetpub\wwwroot\ArcGIS\Tokens\web.config

  • If the Token Service is accessible, see if you can generate a token.

          https://<server>/ArcGIS/Tokens/gettoken.html

If you can generate a token, but it still doesn’t work, check the error message from ArcGIS.com (use the browser developer tools to track requests). If you get a http status 500 error, it may mean that our servers do not trust the certificate given by this Url. This sometimes happens when SSL providers change their root certificates and we don’t have the most recent ones. No self signed certificates.

0 Kudos
KendellRyan
Occasional Contributor

Aha, so that is the issue, we are now using web tier authentication.  That is unfortunate, we'll have to revert to Silverlight viewers.

Thanks for the timely response.

0 Kudos
JoseSanchez
Occasional Contributor III

Hello Mike,

 

How do you implement this token based solution to a Web AppBuilder  application?

 

0 Kudos