Unable to change symbol on one layer in a web map

4093
5
12-09-2014 04:19 AM
PeteCrosier
Occasional Contributor III

Has anyone experienced the inability to change symbol on one layer in a web map, whilst it works on the rest / others?

I have a point layer that doesn't do anything when I go to Change Symbols - Option - Change Symbol, but in the Chrome logs I can see some error messages which don't happen on the other layers in my map (including other point layers).

The log is:

arcgisonline.js:2615 Uncaught TypeError: Cannot read property 'color' of undefined

arcgisonline.js:2615 b.declare.updateUI

arcgisonline.js:2610 b.declare.init

arcgisonline.js:7075 b.declare.showSymbol

arcgisonline.js:4182 b.declare._onSimpleChangeSymbolClick

dojo.js:176 (anonymous function)

dojo.js:176 (anonymous function)

dojo.js:243 g.(anonymous function).h

base.js:98 b.onItemClick

base.js:93 (anonymous function)

dojo.js:219 (anonymous function)

.. any clues? Thanks.

0 Kudos
5 Replies
Reynaldde_Castro
Occasional Contributor

Did you add the layer individually by specifying the layerId rather than the entire map service? This should give you the option to change the symbology.

ChayaBalsiger
Occasional Contributor

I was having the same problem as Pete and I tried this and it worked for me...thanks!

0 Kudos
XanderBakker
Esri Esteemed Contributor

Try removing the layer and adding it again.

0 Kudos
PaulLohr
Regular Contributor

Pete, did you get this resolved?

0 Kudos
MikeDavis5
New Contributor II

I am having the same problem. I tried removing and adding the layer, but that didn't change the options -- no "change symbol."

0 Kudos