Unable to access Vector Tile Layers in ArcGIS Pro from ArcGIS Online

419
4
11-19-2019 12:59 PM
Rohit_Venkat_GandhiMendadhala
Occasional Contributor

I created a custom base map to just hide the labels of the Hybrid Reference Layer in the Vector Tile Style Editor Portal and then saved it to AGOL. I shared the vector tile layer with a group for which I am the group owner/manager. Now when I log in to ArcGIS Pro and try to import the layer from the catalog, it shows a broken link like below. 

When I navigate to the data source URL, it says that I do not have permission to access this resource.

I also tried downloading the JSON style( root.json) and tried importing it in ArcGIS Pro. But it didn't even show that as an option to do. Is there something I am missing here?

One weird thing, I observed is when I share the customized hybrid reference layer openly (Everyone/Public) then I am able to access the layer without any issues in ArcGIS Pro? Not sure what is the reason though.

Appreciate it if anyone could throw some light on this!!.. Thank you.

4 Replies
MarkBockenhauer
Esri Regular Contributor

Instead of trying to set the data source path,  try adding the "style" it will appear as a Vector Tile Layer when you search for it in ArcGIS Pro's catalog pane.  This article shows it..  /blogs/bock/2019/07/03/using-arcgis-pro-to-put-esri-vector-tile-basemaps-in-your-mobile-map 

mark

Rohit_Venkat_GandhiMendadhala
Occasional Contributor

I did the same at first try. I added this vector tile layer.

zx
by
New Contributor II

This is still an issue, my organization does not allow sharing to the public, but exactly what was described above is happening to me. I have another org that does allow open sharing and my customized tile layer came through. Any updates?

zx
by
New Contributor II

Is this possibly a bug? or perhaps a setting that needs to be turned on for things shared only to the organization?