Tiled image in ArcGIS Online does not let me zoom in far

7355
32
Jump to solution
11-10-2016 11:24 AM
Highlighted
MVP Notable Contributor

I have published a tiled image and I have set the visibility range to the max. However, it doesn't stay. Take a look:

But, as soon as I set it, and zoom it, it changes back to its own preset default for no good reason. Is there any way around this? Is this a bug in ArcGIS Online?

Please help!

A link to the web map: http://arcg.is/2fouTew 

1 Solution

Accepted Solutions
Highlighted
Esri Frequent Contributor

As another suggestion to get access to the basemap tiling scheme in ArcGIS Pro,

1. Go to your content and select Add Item from the Web

2. Copy the url for the world topo basemap for the URL, including a title and tags

World_Topo_Map (MapServer) 

3. In ArcGIS Pro, pick use Existing cached Map/image service and select the new item you created.

Make sure that you check out the additional tiles that will be generated when generating tiles down to all scale levels.

-Kelly

View solution in original post

32 Replies
Highlighted
Occasional Contributor III

From looking at the service authoring your web map, I'm seeing that your tile cache ends at Lvl 19 or 1:1,128. The Topographic basemap goes to 1:70 so the preset default shown in your second image reflects that your map service has no tiles to render below that zoom level.

Try adding cache levels below 1:1,128 and see if that fixes the behavior.

Highlighted
MVP Notable Contributor

Seth,

This is great information and makes perfect sense. But, how do I add these levels?

When I published the service, I moved the slider bar to the most maximum level that I could:

It did not allow me to go beyond 1,128. Do I need to "cache manually on the server" versus "cache automatically on the server"? Or choose a different Tiling scheme? (Are there better options to publish images in ArcMap versus ArcGIS Pro?)

Thanks again.

Reply
0 Kudos
Highlighted
MVP Notable Contributor

Maybe I answered my own question by changing the tiling scheme. I moved it from the default ArcGIS Online to WGS84 and it gives me the option for 1:71 and 22 levels (but the cached size dramatically increases from <1 MB to 12 MB, but I suppose that would be expected).

I will try this.

Reply
0 Kudos
Highlighted
Occasional Contributor III

I haven't spent much time caching/creating tile packages in Pro so I won't speak to that. However, from looking at the Help Documentation on Hosted Tile Layers just now, it seems that such Layers' cache levels are capped at 1:1,28 (someone correct me on this if I'm wrong). Such a limitation is different from ArcGIS for Server of course which is where my head was when I replied initially.

Also, changing the tiling scheme from ArcGIS Online is likely to cause rendering issues between your tile layer and other ESRI content that were created in the ArcGIS Online tiling scheme. 

Highlighted
MVP Notable Contributor

Well, you got that right about rendering issues. I was super excited that this might be the answer but, when I loaded it to my map, this is the message that I got

"The layer can not be added to the map because its coordinate system or tiling scheme can't be adjusted to align properly with the basemap."

I can load the image plainly with no map behind it and it behaves like I would want (zooming in far).

So it sounds like the best option is to publish this image to a server? Other than that, I do not know how it can be handled in just plain ArcGIS Online...

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

As another suggestion to get access to the basemap tiling scheme in ArcGIS Pro,

1. Go to your content and select Add Item from the Web

2. Copy the url for the world topo basemap for the URL, including a title and tags

World_Topo_Map (MapServer) 

3. In ArcGIS Pro, pick use Existing cached Map/image service and select the new item you created.

Make sure that you check out the additional tiles that will be generated when generating tiles down to all scale levels.

-Kelly

View solution in original post

Highlighted
MVP Notable Contributor

Kelly,

That is a great idea. I'll try it on Monday and update this thread.

Reply
0 Kudos
Highlighted
MVP Notable Contributor

Wow, that worked perfectly! I didn't even have to load the map into my layout. 

When you choose the drop down for "Existing cached map/image service"

It prompts you to find the service, not by looking in your table of contents. I just went to All Portal, typed in 'world topo map', choose the "World Topo Base", and then I was able to adjust my details levels to 1:71!

Thanks for the help, Kelly!

Highlighted
Esri Frequent Contributor

Adrian Welsh

There is another workaround that you can use that may be helpful when creating a tile service in ArcGIS Online that you want to access at larger scales.

You can enable tile-resampling on your hosted tile service. This will allow the service to draw at smaller scales based on previous tiles that exist.

To do this,

1. Navigate to the admin directory of the published service:

https://tiles.arcgis.com/tiles/<org-id>/arcgis/rest/admin/services/<service-name>/MapServer/edit  (You will be prompted to login. This login has a case sensitive username so be aware of the case of your username)

2. In the Edit dialog box, set the following Service Definition Parameter: {"resampling":true}

REST API documentation: http://resources.arcgis.com/en/help/arcgis-rest-api/index.html#/Edit_Service/02r300000222000000/