"Layer did not draw completely" error in AGOL

06-12-2018 12:03 PM
New Contributor II

I have a point layer in AGOL that has stopped displaying any of the features. Instead, I get an error message saying "The layer, Trees, did not draw completely". The attribute table says there are 1242 features, but the columns are all blank, with only the names displayed. 

The problem started after I had added columns called Y (alias Lat) and X (alias Long) to the attribute table, then tried to delete them. The Long column deleted, but the Lat column is still displayed. When I try to delete it, nothing happens (no error messages). I can show/hide the column, but if I try to do a calculation, I get an error saying "Invalid column name 'Y'". 

I have tried to export the layer to a GDB in AGOL, but I get "Error exporting data to filegdb format".

I have tried to open the layer as a hosted feature layer in ArcMap, but it shows a blank layer with no points. The attribute table is also completely blank, without even any field names. If I try to edit the layer in ArcMap, I get an error saying "The workspace containing the data cannot be edited". I have also tried to export the layer in ArcMap, but I get an error code 400 (Cannot perform query due to bad syntax).

Unfortunately, I made some major changes to the map since my last backup, so I'm really trying to avoid deleting the layer and starting again with older data, add all the attachments, etc.

Is there any way I can recover this layer? I'm out of ideas.

Here is the map: https://mcc.maps.arcgis.com/home/webmap/viewer.html?webmap=ab71379f4d894c33a7c9cf2431e9e16d 

0 Kudos
0 Replies