Public Maps Not Public - Requires Login?

10138
23
10-04-2012 08:01 AM
MichaelSemenek
New Contributor III
I created several public "Web Maps" and "Web Mapping Applications" in the past. No problems - they work great on my Verizon HTC smart phone. But now every time I try to make a web map public and\or web mapping application public. Its not public. The Access and Use Constraints URL redirects to the arcgis online login page on my phone? What am I missing? Is anyone else running into this issue?  Shared with Everyone (public) is checked "ON".....

My workstation opens up the application just fine... My phone redirects to the log in page.

I used the "Make Web Application" with the new "Simple Map Viewer" template.
Tags (2)
23 Replies
BaffourAwuah
New Contributor III

Additional questions I would be asking you are:

Do you have an ArcGIS Server? YES

Do you have an ArcGIS Server with rest services open to the public? YES

Did you setup token security on your ArcGIS Server? YES

Is the rest service secured? If "Yes". Did you add the rest services into AGOL from your ArcGIS Server? If "Yes". Did you save the user account and password to open the layer up in an AGOL web map. (So users do not need to log into ArcGIS Online and then log into the ArcGIS Server rest services to open up the secured data.) YE

I added more service to the portal but whiles  all (except one) were able to open without logging, the main one ( Registreringsplantefelter2) appeared for some few seconds on the content list and then vanish.  Below is the link:
Sorry the services are in Norwegian :).
0 Kudos
BF_TadejBevk
New Contributor

Resurfacing this thread with similar issue on AGOL.

If I create a Web Mapping application from the Map Viewer with Simple Viewer template, when shared the user is redirected to login page:

https://uni-lj.maps.arcgis.com/apps/View/index.html?appid=5ae7930aae04460fb13bf16d6d720a31 

Using the same Web Map and procedure but with Minimalist template, the user has no problem accessing the web app:

https://uni-lj.maps.arcgis.com/apps/Minimalist/index.html?appid=e07d276afe6a4bd081121e8c4b8bc976 

The map itself can also be accessed:

https://www.arcgis.com/home/webmap/viewer.html?webmap=58783708bc0d461da104b8ce138b1a52&extent=13.454...

Could there be a widget in the Simple Viewer causing the bug?

(I'm testing on Chrome in Incognito tabs) 

0 Kudos
Brown_Becky
New Contributor

I had the same issue in the Information Lookup template. The web app is embedded in our website as an iframe and there's also a hyperlink to it on the same page. The embedded iframe works with no problems, everything is shared publicly, no sign in required. When clicking the hyperlink, however, the app would open in another tab, and require a sign in. I opened the web map itself to test it and there were no issues opening it that way; something in the wep app template was forcing the sign in. 

It finally worked after I went to configure the Information Lookup application we created and unchecked the 'Show the basemap selector' under Options. Now the hyperlink works on the website and does not require a sign in. When this option was checked, the basemap selector worked fine in the embedded iframe, but not with the hyperlink. 

I hope this helps others.

JohnChurchill
New Contributor III

This was precisely where I was stuck as well. Thank You! ... Thank You! ... Thank You!

0 Kudos