Pop-ups in the Basic Viewer web app template in ArcGIS Online

918
8
08-09-2016 10:51 AM
Highlighted
New Contributor II

My pop-ups in the Basic Viewer web app template in ArcGIS Online are not displaying the arrows and "x" close out button properly. (see snapshot below).  Does anyone know what could be causing this issue? Also, is there an easy way to "dock" popups when using the other web app templates? Thanks!

Reply
0 Kudos
8 Replies
Highlighted
Esri Frequent Contributor

I just ran a quick test and using this app the arrows do show up. Is your web app public? If so can you share the link.

https://diygeoapps4.maps.arcgis.com/apps/View/index.html?appid=4a8f7b2f660e4c95bfe604c19b9d673a

You can also display popup content in a side panel in the minimalist template.

Reply
0 Kudos
Highlighted
New Contributor II

Thanks for your reply! When I opened your app using Internet Explorer I received the same error on the arrows, but when I opened it with Google Chrome it worked normally. However, it is only my newer applications that are giving me this error in Internet Explorer.

Internet Explorer:                                                            Google Chrome:

   

The apps are currently only shared internally, but may be public in the future.

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Could be an app bug in IE.  I'll setup a test which version of IE are you using?

Reply
0 Kudos
Highlighted
New Contributor II

IE 11,  specifically, Internet Explorer Version 11.0.9600.18059. Thanks!

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Thanks Tanya. I was able to reproduce the issue and will work on fixing this for the next release of online. It also may be able to fix this using the custom css option on the template configuration panel. I'll look into this tomorrow and provide an update.

Reply
0 Kudos
Highlighted
New Contributor II

Thank you Kelly! I really appreciate your help!

Reply
0 Kudos
Highlighted
Esri Frequent Contributor

Ok it is a bug and we'll get it fixed for the next release. In the meantime you can fix it in your application by clicking the 'Configure App' button and then selecting the Theme option and pasting the following css into the 'Custom css' text box. Let me know if you have any questions about getting the fix working in your app.

.popupButton{overflow:visible;}

Highlighted
New Contributor II

Thank you! I applied the fix and the app is now working perfectly!