New Map Viewer Page Unresponsive/Slow Loading when editing features compared to Map Viewer Classic

449
4
07-14-2021 03:22 PM
Labels (2)
cnw_ivesleung
New Contributor II

When selecting a feature in edit mode using Map Viewer, the webpage keeps returning an unresponsive page dialog and takes an unreasonably long time to load. This does not appear to be an issue when using Map Viewer Classic or Field Maps. As a result, the city staff are discouraged from using the new Map Viewer. Hopefully, this post can help me resolve it.

The issue with the long loading times may be coming from loading ~26,000 addresses in the domain list. I've created a test layer for anyone to look into it further at https://newwestcity.maps.arcgis.com/apps/mapviewer/index.html?layers=562ed6ba72474782b67d49f1b002a31...

Thanks,

Ives

Tags (3)
0 Kudos
4 Replies
KeirenMarshall
Esri Contributor

Hi @cnw_ivesleung , 

Is your data Cached? Caching Maps and Vector Tile Layers: Best Practices Video | Esri

Strategies for creating map cache tiles—ArcGIS Server | Documentation for ArcGIS Enterprise

Are you using ArcGISOnline or ArcGIS Portal?

Esri Australia Consultant and Business Analyst
0 Kudos
cnw_ivesleung
New Contributor II

Hi Keiren,

Thanks for your reply and for providing the links. I'll have a look. The basemaps are cached and for the tree inventory I've rebuilt the spatial index.  

I am using ArcGIS Online. 

 

Ives

0 Kudos
RussellRoberts1
Esri Frequent Contributor

Looking into this Can I ask why you have 26k domains? 

0 Kudos
cnw_ivesleung
New Contributor II

Hi @RussellRoberts1,

Thanks for the reply. The address domain contains 26k addresses so that the arborists can input the address using Field Maps and make the selection easily with predictive text. 

Ives

0 Kudos