Map Tile Package Is not Displaying Content on ArcGISOnline

80
1
09-23-2021 02:13 PM
saraew1
New Contributor

I have an airquality map(raster data) for the US which I am trying to upload on ArcGIS online so my organization can share that on their website. Unfortunately, I cannot share as web-layer since we do not have any remaining credits. Therefore, I am using 'Create Map Tile Package' tool to create a tpkx which I am then uploading in our content. However, when I display the layer in Map Viewer, it randomly centers in the middle of the map and none of my data shows on MapViewer. I have shifted the min and max levels of details as well and I cant seem to find a solution.

 

This entire problem has taken me more than 15 hours and I really do not know what else to do to find a solution. Any help is highly appretiated. 

 

saraew1_0-1632431460988.pngsaraew1_1-1632431585548.png

 

0 Kudos
1 Reply
Brooks_SummitGeo
Regular Contributor

@saraew1 have you tried creating a standard TPK instead of TPKX?

Also, when you upload the TPKX to AGOL, are you then creating a hosted tile layer? In the settings of that hosted tile layer, can you see the cached tiles in the cache table?

Also, when you're creating the original tpkx, are you using the standard AGOL tiling schema, or a custom schema?

Also, have you set your coordinate system of the data frame to Web Mercator auxiliary sphere before creating the tile package? It looks like youve tried to add it as a layer within the Map Viewer, so needs to be in epsg3857. If you want it as a basemap in a different coordinate system, you can 'add as a basemap' and that will then set the SRS for the web map.


David
..Maps with no limits..
0 Kudos