Local cached services not displaying below a scale of 1128 in AGOL web map.

5593
4
12-10-2015 10:45 AM
MichaelSemenek
New Contributor III

Several issues:

  1. When you first create a cached map service using the “ArcGIS Online / Bing Maps / Google Maps” tiling scheme.  There is not an option to set the scale below 1128.497176. We are using version 10.3 - No patch available so far on ESRI’s web site.
  2. Any local cached services using this tiling scheme will not display in a web map below a max level of 1128.
  3. In ArcGIS Server - Altering the tiling scheme “Maximum Scale” on an existing cached service has no effect on displaying the cached service at a lower scale (Example: I set the max scale to 1:71). The cached service will not display and still disappears from the AGOL web map when you zoom in below a scale of 1128.

My only option was to add a new cache scale of 564.248588 using the “ArcToolbox” tool called “Manage Map Server Cache Scales”. Then use the “Manage Maps Server Cache Tiles” tool and recreate empty tiles for the new cache scale of 564.248588.

I ran a test: I created a cached service using our high school district boundaries with the new cache scale of 564.248588. It works... I can view the cache below a scale of 1128 to the new scale of 564. However it still disappears if you zoom in even closer to a scale of 1:71.

Scales levels taken from World_Imagery (MapServer)​​​ Level ID's.

Another Issue: I created a new cache level of 564 for our counties contour data. It has been running for almost 20 hours. I just viewed the tile cache status and its 79.8% done – Tile generation is still in progress.  If I have to update all our cached services, this is going to take a long time to finish and take up a lot of additional storage space. And I still cannot view the cache below 564. This data must be cached.. To much data to be displayed as just a map service (Non-cached).

Unfortunately using the “Set visibility range” option in an AGOL web map has no effect on displaying an existing cached service at a lower scale. It resets back to the Max scale of 1128. 

Has anyone figured out a workaround?  Thanks.

4 Replies
ChrisWhitmore
Esri Regular Contributor

Hi Michael,

You can do this as part of the publishing process in ArcMap:

1) add http://services.arcgisonline.com/arcgis as a GIS Server connection in ArcMap / Catalog.

2) go through the publishing process as usual. In the Service Editor -> Caching section, select 'An existing cached map / image service' (this should be in the same dropdown where you see the ArcGIS Online / Google / Bing Tiling Scheme option).

3) After selecting the option to specify an existing cached service, browse to your GIS Server connections and select the connection you created in step 1 and select the 'World_Topo_Map' service.

4) Click Add to select the service and close the browse dialog..back at the service editor caching dialog, you should now see all 24 levels, down to 1:70.x, as your available levels of detail.

(For the issue you mentioned about the cache job still running, the best option is to contact Technical Support - they'll be able to troubleshoot.)

Thanks,

Chris

MichaelSemenek
New Contributor III

Hi Chris,

I appreciate the tip on how to load the tiling scheme from the world topo map. That works. But I think the levels should be made available in the ArcGIS online / Google / Bing tiling scheme “default” selection as well. My cache process succeeded – Results show a run time of 29 hours 59 minutes and 17 seconds.  Granted I only cached next scale below 1128 (or 564). If I run all the levels from the world topo map service down to 1:71…. I’m concerned the process will take a month or two to complete. I think I need another server just to run cache processes!!!  I wish you could display an existing cache level (Say 564) to the base cache level of 1:71 (Even if the cache appeared to be a little pixelated in your web map) at least it would display and not disappear.

Thanks again for the tip on how to load the tiling scheme,

Mike 

Reply
0 Kudos
JaniceBaird
Occasional Contributor II

Hi Michael,

I am not sure about AGOL and do not have an answer for you... just a suggestion. When you are able to add the cache levels below 1128, set the option to allow the cache to be generated on the fly. That way you are not spending 29+ hours generating an entire level of tiles when there may only be a few areas that will actually be visited at that level. This will save you time and disk space!

Janice.

Reply
0 Kudos
RyanNosek
Occasional Contributor II

Issue from OP: displaying service beyond lowest cached level

This question/answer is found in a few different posts:

https://community.esri.com/thread/173082 (Ryan Kelso answer on March 10th 2017)

https://community.esri.com/thread/185761-tiled-image-in-arcgis-online-does-not-let-me-zoom-in-far (Kelly Gerrow‌ answer on Nov 21, 2016)

To summarize the answers already provided in those links: You'll need to add a string to the properties on your ImageServer or MapServer resource that contains the cache using ArcGIS Server Admin Directory. 

"resampling": "true" -> save your edits

TIP: For ArcGIS Server 10.3, I found that changing the "maxscale" property to the desired lowest scale (in addition to adding the resampling property) did not produce the desired effect of showing my cache below my lowest cached scale. Instead, I had to use ArcMap/Catalog Server Toolset --> Caching --> Manage Map Server Cache Scales --> select your service, then add the desired cache scales (e.g. 282.124294, 141.062147, 70.5310735) and ran the tool. 

Running this tool creates additional scale levels for your cache, but does not create the actual tiles. However, we found these empty scale levels necessary to be able to use the "resampling" feature.

As an aside, I am curious why the "resampling" feature isn't be baked into the ArcGIS Server GUI or publishing workflow? Instead it seems to be a hidden extra, like a google Easter egg. Regardless, glad its even an option!

Issue from OP: Slow cache creation speeds

Esri best practices notes that creating a cache will go a lot faster if the data for the cache you are creating is local to the machine you are publishing to. By doing this, you are removing an unnecessary networking burden for the millions of requests that occur when publishing a cache. "If the data does not have to leave the machine, your tiles will draw more rapidly."  I found this tip to be especially important and extremely helpful, and relatively easy to overlook for cache creation workflows. Caches that used to take 24 hours are taking just an hour or two at the most now.  

Reference: Accelerating map cache creation—Documentation (10.3 and 10.3.1) | ArcGIS for Server