Item Description changed when uploaded to AGOL

111
1
09-19-2020 04:58 PM
ZacharyUhlmann
New Contributor III

This is the text in the Summary(Purpose) section of my Item Description as seen in ArcMap (right click Item Description):

DATA_LOCATION: C:\Users\zach\Box\GIS\Project_Based\\GIS_Data\AGOL_DataUploads\2020_09_17\2020_09_17
DATE_RECEIVED: 09/11/2020

Once posted to ArcGIS Online as a shapefile and/or the published Feature Layer it becomes:

DATA_LOCATION: 2020_09_17
DATE_RECEIVED: 09/11/2020

F R U S T R A T I N G !.  This is important metadata and is being stripped.  I don't understand.  Originally I was editing the xml file in Python using xml.etree.ElementTree module.  It worked well to batch update metadata to basically create or append new metadata in the xml that populates the Item Description.  I tried in ArcMap manually to see if my xml updates in Python passed text with parsing issues BUT it occurs with Item Descriptions created in ArcMap and in Python.  Clearly seems to be a text parsing issue but seems pretty negligent by ESRI to be stripping metadata.  And yes, I've uploaded to AGOL then downloaded the same data and it comes back stripped as well.  Please Help!  

Tags (1)
Reply
0 Kudos
1 Reply
ZacharyUhlmann
New Contributor III

Turns out to be more of an xml parsing problem than Arc.  Swapped out the backslashes \ with forward slashes /.  I used two // for good measure and my Item Description troubles were over.  Good job Zach!  Geonet Community abandoned me, but all is forgiven I still like you guys