How to use/get my uploaded image to symbolize layer

773
5
02-10-2021 07:16 AM
Labels (1)
Patricia_Foster
New Contributor II

First, I just tried to use a link which pointed to a solution for what sounded like my problem, but got a page error.  In MyContent I have a simple image of a blue triangle.  I copy the URL at top when I click on my image, and paste it into the box for "Custom Image" where you change symbology for a layer.  It says URL not recognized.  I must not have the correct URL format somehow?  How do I get that?

0 Kudos
5 Replies
VickyWang
Esri Contributor

go to your image content's item details. copy the URL at the bottom.

past the URL into a new tab of the browser, make sure you can see the image in the new tab. 

use the URL for your custom image. make sure your image type are: jpg,gif,jpeg . the image size is 120x120 pixels.

~Vicky Wang~
0 Kudos
Patricia_Foster
New Contributor II
I do not see a URL anywhere for my image. I am in MyContent on our Enterprise Portal, and View the item details, and everything else I can imagine might show me the URL, and I still don't see it.
0 Kudos
VickyWang
Esri Contributor

In the item details page of your uploaded item. are you able to see the URL on the right-bottom of the page? 

Click on the view link, next to the URL. it then opens a new tab in the browser and shows your image. 

VickyWang_0-1613270288616.png

 

~Vicky Wang~
0 Kudos
Patricia_Foster
New Contributor II

Hi Vicky:

 

Still haven't been able to use my image.  It's a simple blue triangle that I found out on the web.  I do know what you mean by the URL that shows at the bottom right when you choose an image.  I have seen that with other images I have.  But the difference may be that my blue triangle is not a "Map Image Layer?"  I do see the URL on some other map image layers I have.  But when I bring in this triangle, it also only allows me to View in ArcMap or PRO.  So something needs to be changed with the image itself. 

I have another image, a .gif, from a customer that I want to use as a symbol.  When I try to "Add Item" and add this .gif, it says that type is not supported.  When I try to Add a .png, it comes into my content no problem.  But still  no URL.

0 Kudos
VickyWang
Esri Contributor

Sory didn't get back to you since last time. Found that ArcGIS Online behaves differently from Portal.  The image item can upload from png type but only download or share available that has no URL link. 

Another workaround is to use ArcGIS Desktop (ArcMap or ArcGIS Pro) to publish the hosted service with custom symbology to ArcGIS Online? 

To select the picture marker from the Symbology -> Format Point Symbol. Click File to select the image from jpg or png. Try to avoid the complicated images, it might not have a good result when you publish to ArcGIS Online. 

Share as >> Service >> My Hosted Services will transfer the data and its symbology to the online service.

VickyWang_1-1615846669243.png

VickyWang_2-1615847253813.png

 

 

 

~Vicky Wang~
0 Kudos