How to avoid concatenated fields in AGOL when importing unique value symbology

221
1
2 weeks ago
Highlighted
by
New Contributor

In ArcGIS Pro I symbolised a polygon layer with unique values using two fields, with those two fields in the attribute table looking sort of like this:

FinishedArea
YesFjord
NoLake

There's one color for yes+fjord, one for no+fjord, one for yes+lake, and so on. When I share this as a web layer and open in AGOL the Finished field is concatenated with the Area field so that it looks like this:

FinishedArea
Yes,FjordFjord
No,LakeLake

The field has not been concatenated in ArcGIS Pro.

The problem is that the plan is for my coworker to only access the attribute table and change the Finished field to update the map but now that it's somehow automatically concatenated there is a bigger chance of typos and mistakes (the table is in reality quite large, with only yes and no options in the first field but many more in the other).

Is there a way to avoid concatenating the fields but still symbolising using two fields in AGOL? I suspect Arcade could solve this, but haven't figured it out myself.

Thanks in advance.

Tags (2)
Reply
0 Kudos
1 Reply
Highlighted
Esri Esteemed Contributor

Hi @SiljeB ,

 

If you want to try out Arcade, you can create a new expression for the symbology and do the concatenation virtually and visualize the result.

Simply use something like:

$feature.Finished + ", " + $feature.Area

 

Reply
0 Kudos