Select to view content in your preferred language

Dashboards Asking for Me for Login Prompt

800
1
Jump to solution
02-02-2022 09:45 AM
PaulinaMarczak
New Contributor III

I am having a problem where I get a "Login to ArcGIS Online" prompt when using alternate accounts for my Dashboard:

PaulinaMarczak_1-1643823652559.png

If I click "Cancel", then the data does not load and the network log shows the following:

PaulinaMarczak_0-1643823612638.png

If I click "OK" instead of "Cancel", then the Dashboard loads and displays fine.

I created this dashboard using an organizational-shared account that we use for creating new apps.

The dashboard only has one feature layer. 

The map associated with the dashboard does not ask for a prompt with alternate account login. 

The dashboard is available and shared for my personal account and the viewer account. Both of these accounts are prompted for a login after the usual login page.

How do I change this so that this login prompt goes away?

0 Kudos
1 Solution

Accepted Solutions
PaulinaMarczak
New Contributor III

I figured it out! The dashboard needed to have the #view specified in the URL after in the storymap series URL parameter. So instead of https://governmentofbc.maps.arcgis.com/apps/dashboards/itemid i did https://governmentofbc.maps.arcgis.com/apps/dashboards/itemid#mode=view and it works for everyone now.

View solution in original post

0 Kudos
1 Reply
PaulinaMarczak
New Contributor III

I figured it out! The dashboard needed to have the #view specified in the URL after in the storymap series URL parameter. So instead of https://governmentofbc.maps.arcgis.com/apps/dashboards/itemid i did https://governmentofbc.maps.arcgis.com/apps/dashboards/itemid#mode=view and it works for everyone now.

0 Kudos