coordinate system or tiling scheme can't be adjusted to align properly with the basemap

312
4
Jump to solution
03-19-2021 09:08 AM
Labels (2)
Jean-SebastienLauzon
New Contributor III

I am trying to create a AGOL web map using this WMS as the basemap:

https://wms.geonorge.no/skwms1/wms.nib

That works. But then, when I try to add a hosted tile layer that I created in ArcGIS PRO to that map on AGOL, I get this error:

The layer, LAYER_NAME, can not be added to the map because its coordinate system or tiling scheme can't be adjusted to align properly with the basemap.

I don't know what the coordinate system of the WMS is.

What can I do to make this work?

0 Kudos
1 Solution

Accepted Solutions
Tim_McGinnes
Occasional Contributor III

In Pro, it's important to set your map to the required coordinate system first. So I choose WGS84 for my empty map. Then go to the Insert tab and choose Connections -> New WMS Server. Paste the URL (same as you first post) and click OK. Then in the catalog pane, expand the Servers, find the Ortofoto layer and add it to your map. I can also choose any of the WMS listed coord systems and set my map to those, and the WMS will come in ok. For example I chose ETRS 1989 UTM Zone 36N and the WMS came in as shown in the screenshot.

The default basemaps in AGOL are Web Mercator EPSG:3857. That is why they won't overlap. You may have to find an actual WGS84 basemap. Hopefully there may someone from ESRI who understands the ins and outs of AGOL who may be able to help with that side of things.

View solution in original post

4 Replies
Tim_McGinnes
Occasional Contributor III

You can load the WMS layer into ArcGIS and look at the Properties. Screenshot attached shows the layer and that the spatial reference is WGS84 (EPSG:4326).

You can also do a GetCapabilities request on the WMS service itself:

https://wms.geonorge.no/skwms1/wms.nib?service=wms&request=GetCapabilities 

It shows that the service supports quite a few different coordinate systems:

<Layer queryable="1">
<Name>ortofoto</Name>
<Title>ortofoto</Title>
<Abstract>ortofoto</Abstract>
<CRS>CRS:84</CRS>
<CRS>EPSG:4326</CRS>
<CRS>EPSG:25833</CRS>
<CRS>EPSG:32632</CRS>
<CRS>EPSG:32633</CRS>
<CRS>EPSG:32634</CRS>
<CRS>EPSG:32635</CRS>
<CRS>EPSG:32636</CRS>
<CRS>EPSG:25832</CRS>
<CRS>EPSG:25833</CRS>
<CRS>EPSG:25834</CRS>
<CRS>EPSG:25835</CRS>
<CRS>EPSG:25836</CRS>
Jean-SebastienLauzon
New Contributor III

Thanks @Tim_McGinnes  that was very useful!

I am confused though because when I load that WMS in AGOL, I get the message that:

"The item, WMS, can not be added to the map because its coordinate system can't be adjusted to align properly with the basemap."

and the only way I can add it is by specifying the "Use as Basemap" option. If it is in EPSG:4326, wouldn't it be aligning with the basemap? Also, the subsequent tiling service I'm trying to add is also in EPSG:4326 but that fails as explained in first message.

I've tried loading that WMS in ArcGIS Pro and it connects and I can add it to a map, but nothing is visible and when I Zoom to layer, it brings me to 0E, 0N.  The WMS properties in ArcGIS Pro indicate that the Spatial Reference is Unknown Coordinate System.

If I load it in QGIS, it displays fine.

I'm confused....

0 Kudos
Tim_McGinnes
Occasional Contributor III

In Pro, it's important to set your map to the required coordinate system first. So I choose WGS84 for my empty map. Then go to the Insert tab and choose Connections -> New WMS Server. Paste the URL (same as you first post) and click OK. Then in the catalog pane, expand the Servers, find the Ortofoto layer and add it to your map. I can also choose any of the WMS listed coord systems and set my map to those, and the WMS will come in ok. For example I chose ETRS 1989 UTM Zone 36N and the WMS came in as shown in the screenshot.

The default basemaps in AGOL are Web Mercator EPSG:3857. That is why they won't overlap. You may have to find an actual WGS84 basemap. Hopefully there may someone from ESRI who understands the ins and outs of AGOL who may be able to help with that side of things.

View solution in original post

Jean-SebastienLauzon
New Contributor III

Thanks again, this works indeed in ArcGIS PRO

Based on your suggestion, I looked and ESRI has a whole range of WGS84 basemaps.

I used one of those  World Basemap (WGS 84) and then the WMS could load as a layer. Then I realized I had made a mistake when publishing my tile service and while the raster was in WGS84, I had not specify the tiling Scheme to use (under the Configuration tab). Once I changed the default to WGS84 GCS Version 2 and published it, I was able to load it in my AGOL map along with the WMS.

Thanks for your help!

 

0 Kudos