Cannot share hosted feature layer with Everyone (public)

1374
4
Jump to solution
11-03-2023 10:32 AM
Labels (2)
bshvid
by
New Contributor II

I have an AGOL account with a layer that I have been using for a custom application that I built using ESRIs ArcGIS JavaScript API. I’ve been editing the layer in AGOL to update its contents (with the sharing level set to ‘Owner’ so that I could perform those edits) and then when finished changing the sharing level to ‘Everyone (public)’ in order for my layer to show up on my application. I’ve been successfully performing this workflow for about a year now with no issues. Earlier this week, around 10/31, I made edits to my layer and when I attempted to change the sharing levels from ‘Owner’ to ‘Everyone (public)’ , the ‘Everyone (public)‘ sharing option got grayed out. I now cannot share the layer publicly, even though I have been able to do so for the past year. I also get the following message in the Sharing window: 'Some share level options are limited by your sharing privileges.'

The only change that occurred was me editing the layer. I did not change any settings with the layer or my profile. I double checked everything and couldn’t identify any obvious reason to why I now cannot share my layer publicly. As a result, my application cannot use my layer.

I was wondering why this happened, and if there is a solution. Perhaps I am missing something obvious, but haven’t been able to figure out the root cause of this issue. I am an administrator as well and double checked my ArcGIS Developers account to make sure nothing got changed there, I couldn't find anything obvious.

Has anyone run into anything similar before?

Thanks for any help!

0 Kudos
1 Solution

Accepted Solutions
bshvid
by
New Contributor II

After digging around for a while, I found that assigning a content scope to the API key that I was using to authenticate my layer (and as a result have it available to the public in my application) seemed to solve the issue. I still cannot share my layer to everyone in ArcGIS Online, but my layer now shows up in my application and is available to the public. I'm not 100% positive if updating API key content scope was really the solution (because the sharing to everyone option is still grayed out in AGOL), but it did seem to do the trick.

For those wondering, the steps are:

1. Open  your ArcGIS Developers account Dashboard.

2. Go to API Keys and navigate to the API key that is being used.

3. Select the key and click on Overview, scroll down to the bottom of the page to the 'Maps, layers, and data' window and click 'Set content item scopes'.

4. Select the necessary layer.

Note: Initially nothing changed when I updated the scope, I had to wait a few hours for my layer to show up in my application.

View solution in original post

4 Replies
EmilyGeo
Esri Contributor

Hi @bshvid

To narrow it down, it would help to have more information. Would you be able to share some screenshots, specifically for the layers Editing Settings and the Share dialogue? 

Thanks!

 

 

0 Kudos
bshvid
by
New Contributor II

Hi @EmilyGeo,

Sure thing, here are 2 screenshots of the layer settings. Note that I have not altered these settings before the issue arose. I have tested different checkboxes and setting selections after I noticed the error to see if I could figure out a solution, but have returned them back to how they were when I originally created the layer before the sharing issue.

settings1.jpg

settings2.jpg

 

Here is the sharing dialogue box. The first screenshot below is with me hovering over the 'Everyone (public)' button to display the additional text.

share2.jpg

share1.jpg

I have tried opening AGOL on other browsers, such as Firefox and Edge, but the sharing issue still shows up. Attempting to update the sharing status on mobile resulted in the same issue.

Thanks you! 

0 Kudos
EmilyGeo
Esri Contributor

Hi @bshvid

I don't see any obvious issues with the layer. I think that since you are using a developer account it could have something to do with the api key authentication that is now required to make hosted layers publicly available (more info on api keys here)

If you are unable to resolve it on your end, I would recommend contacting support so they can work through it with you.

Good luck! 

bshvid
by
New Contributor II

After digging around for a while, I found that assigning a content scope to the API key that I was using to authenticate my layer (and as a result have it available to the public in my application) seemed to solve the issue. I still cannot share my layer to everyone in ArcGIS Online, but my layer now shows up in my application and is available to the public. I'm not 100% positive if updating API key content scope was really the solution (because the sharing to everyone option is still grayed out in AGOL), but it did seem to do the trick.

For those wondering, the steps are:

1. Open  your ArcGIS Developers account Dashboard.

2. Go to API Keys and navigate to the API key that is being used.

3. Select the key and click on Overview, scroll down to the bottom of the page to the 'Maps, layers, and data' window and click 'Set content item scopes'.

4. Select the necessary layer.

Note: Initially nothing changed when I updated the scope, I had to wait a few hours for my layer to show up in my application.