Cannot enable offline mode for web map in order to use in Collector

396
6
10-30-2019 03:57 PM
Highlighted
New Contributor III

I've been trying to enable offline mode in a WebMap in order to use one Collector. I reviewed the requirements here however I enabled sync and caching on my feature layer and map layer I believe. Here is the option in ArcServer Manager that shows it as enabled:

What else can I check to ensure that I meet all the requirements in order to enable offline mode in WebMap? And how can I accomplish this. I see all the tutorials online refer to ArcMap, however, I use ArcGIS Pro and I'm having a hard time finding a tutorial that matches the products I'm using.

Reply
0 Kudos
6 Replies
Highlighted
Esri Regular Contributor

For the feature service portal item does it show that sync is enabled?

Mark

Reply
0 Kudos
Highlighted
New Contributor III

No, I did some reading and realized that my Feature Layer isn't "Hosted", what process do I have to go thru to make my feature layer as a hosted feature layer?

Reply
0 Kudos
Highlighted
Esri Regular Contributor

The 'hosted' part of my screenshot is not significant, and actually the rest of it in regards to the settings are not either.  I suspect when  you view the portal item for your feature service, you see something like this..

Since the properties you are showing in your first ArcGIS Server manager screenshot are correct for offline use, it may be that you need to specify a basemap for your webmap that can be taken offline.

If you are using Esri vector tile basemaps with your portal, set the basemap for your webmap to "Navigation" and save the web map.  The Esri vector tile basemaps are extract-able for offline use.

In the map settings do you see "Enable offline mode" ?

Mark

Highlighted
New Contributor III

Hey sorry I moved away from desk for awhile.

So what I did was follow these directions here and use one of these tiled layers here, that are marked "for export". I thought based on the tut that this could be used for offline use?

EDIT: I tried utilizing your suggestion however when I click on basemap I don't have that option:

Reply
0 Kudos
Highlighted
Esri Regular Contributor

The Esri vector basemaps are not enabled for your portal.  That is why you don't see the same basemaps.  However, in your webmap use this item for your basemap.  http://www.arcgis.com/home/item.html?id=63c47b7177f946b49902c24129b87252 

Then check to see if that allows you to enable your basemap for offline use.

mark

Reply
0 Kudos
Highlighted
New Contributor III

So I used the Basemap as shared by the link, but I still don't have the Offline mode available to me 😕

Also I should mention that when a user comes into the office to Sync I would like for the data to be uploaded to a geo-database, therefore my layer references the data source instead of saving the data on the Server. I don't know if that has anything to do with it?

Reply
0 Kudos