Can't login to ArcGIS Online in Power BI Desktop anymore

2385
5
Jump to solution
02-08-2022 10:41 AM
MicheldeBruijn
New Contributor

Hi there,

 

In ArcGIS Maps for Power BI I could normally login to my ArcGIS online account to access my own published maps, but I no longer seem to be able to log in. The space where it asks for a url seems to be greyed out. I can however click on ArcGIS enterprise, but that's not how I have previously logged in. 

My license type is GIS Professional Advanced. 

Any help would be greatly appreciated!

Kind regards,

 

Michel

0 Kudos
1 Solution

Accepted Solutions
MarkWestergaard
New Contributor III

Hi @MicheldeBruijn, I have had luck with clearing the cookies for app.powerbi.com in my browsers. On Chrome it's Settings > Security and Privacy >  Cookies and other site date > See all site data and permissions. That can also be set to clear every time the session closes: Solved: Re: ArcGIS GIS in PowerBI Web Holding Cookies - Esri Community

I also have to keep the "Power BI Desktop infrastructure update" preview feature turned off in Power BI desktop global Options.

View solution in original post

0 Kudos
5 Replies
MarkWestergaard
New Contributor III

I believe you are seeing the correct behavior. If the Sign In is to ArcGIS Online, there is no need for the URL. You should be able to click the yellow "Sign in" button and get a pop-up window for the ArcGIS Online login.

One thing that can be confusing is when your ArcGIS visual is using a dark background (or no background and the report page has a dark background). In that situation, the "Sign in to ArcGIS" window is difficult to see.

0 Kudos
MicheldeBruijn
New Contributor

Hi Mark,

Thanks for your response. 

When I try to click on sign in (or any button for that matter), it does not respond. 

I also tried the tip of @MyrtheAbbenhuis2  to do the following:

 

  1. On your local system, depending on how you installed Power BI, browse to one of the following folder locations:
    • .exe version— %LocalAppData%\Microsoft\Power BI Desktop (for example, <user>\AppData\Local\Microsoft\Power BI Desktop)
    • Microsoft Store version— C:\Users\<user>\Microsoft\Power BI Desktop Store App
  2. Delete the folder named CEF.
  3. Delete the folder named Cache.
  4. Restart the machine.

Yet, I don't see the CEF folder at all at the referenced location(s). I deleted the cache, without result. 

Any help would be appreciated, because this kinda sucks. 

 

 

 

0 Kudos
MarkWestergaard
New Contributor III

Hi @MicheldeBruijn, I have had luck with clearing the cookies for app.powerbi.com in my browsers. On Chrome it's Settings > Security and Privacy >  Cookies and other site date > See all site data and permissions. That can also be set to clear every time the session closes: Solved: Re: ArcGIS GIS in PowerBI Web Holding Cookies - Esri Community

I also have to keep the "Power BI Desktop infrastructure update" preview feature turned off in Power BI desktop global Options.

0 Kudos
MicheldeBruijn
New Contributor

Hi Mark!

Fantastic! Turning off the Power Bi Desktop Infrastructure update seem to have done the trick (for now)! The CEF folder also popped up now in my power BI desktop folder!

Thanks a lot!

0 Kudos
MarkWestergaard
New Contributor III

@MicheldeBruijn Glad it helped. As I understand it, the CEF folder is associated with CEFSharp. When the Infrastructure Update preview option is selected, it will use WebView2 and a folder of the same name.

0 Kudos