ArcMap crashes when sorting on a field with domains in 10.3.1

2157
1
11-09-2015 11:44 AM
Highlighted
New Contributor III

I recently updated from 10.2.2 to 10.3.1, and found that ArcMap crashes if you try to sort on a feature class field that has a domain. I called Tech Support to find out that this is a bug that has been "assigned" to a development lead. I really hope that a patch comes out to repair this problem and here's why. Without this functionality, all of my work in ArcGIS Online stops. All work using Collector stops. Editing data with domains in ArcMap is impossible. So, if ESRI wants us to use ArcGIS Online, then they really ought to make sure that long-established functionality like domains works with each new release. I'm wondering why that part of the code was altered in the first place - there has been no problem with domains since 9.0! I find it to be extremely irritating that I have to now uninstall 10.3.1 and reinstall 10.2.2 just so that I can continue my work.

When will users be able to trust that a new release will be stable and not have something else as basic as domains be broken????

Two bugs in 10.3.1 are listed below. I also find it unacceptable that some bugs are "closed" and are fixed only in the next release.

11-9-2015 2-39-44 PM.bmp

Reply
0 Kudos
1 Reply
Highlighted
Occasional Contributor

Just had this same problem. I don't know whether it was a coincidence, but the case was that the field on which I sorted had values that were not listed in the domain. After adding the missing values, the problem was solved.

Hope this helps anybody having the same issue.

Joris Frenkel, Staatsbosbeheer, the Netherlands