ArcGis Online - how to move a feature

12057
47
Jump to solution
01-14-2016 10:57 AM
MelissaMitchell
New Contributor III

I'm not sure how to move a feature while editing. I can add and delete but can't move the point. I've looked at the properties and full editing has been enabled. I can't figure out how to move the feature to another location.

thank you!

1 Solution

Accepted Solutions
RussellRoberts1
Esri Frequent Contributor

The issue is with the m values being enabled on the feature class when the feature class was created. The feature service then gets the property m values: true. You can see this at the REST endpoint of the feature service: HasM: true. The map viewer prevents the editing of geometries when the m values have been enabled b/c they do not support editing m values and the feature would lose the values on features if you edited there geometry in the map viewer.

View solution in original post

47 Replies
FrankVignati
Occasional Contributor II

this happens sometimes if the features are symolized based on an attribute, if you change the symbol to a location only type it works better

BenjaminMittler
Occasional Contributor III

With editing enabled try clicking on the "Edit Button" located between "Add" and "Basemap". This should bring up a screen allowing you to add data points. While this screen is active you should be able to relocate existing points.

0 Kudos
RussellRoberts1
Esri Frequent Contributor

When you click edit on the feature in the popup, click and grab the feature with your mouse and then you can drag the point feature to that new location.

GlennWilson3
New Contributor

Thanks Russell. With the feature selected you will see the cursor change to the 'hand' when you hover over the line - then you can click and drag

0 Kudos
PamelaQuarles2
New Contributor II

This suggestion worked for me -- thanks!

0 Kudos
RobertThomson
Occasional Contributor II

Same issue here and none of the above seems to help.  I can edit, create and delete but unable to move a feature.  The only to move the feature is to bring it back to my desktop and work on it (slow) or move it in Collector.

0 Kudos
RobertoDeDeus
New Contributor II

I know you said you've checked the permissions but just to verify...

On the feature class, click on edit and look under Properties > Editing section.

Make sure that Add, update and delete features is the option selected.

Capture.PNG

0 Kudos
RobertThomson
Occasional Contributor II

Everything looks fine here:

erase.JPG

0 Kudos
RyanClose
New Contributor III

I've found the same issue, but only with line features. I can edit/move a polygon feature in the same feature service, but the only way I can interact with a line feature is editing the attributes.

HOWEVER

I can edit that line feature using the Collector app on my Android.

I would say it appears to be a bug.

0 Kudos