Arcade calculated field does not show up when export to CSV from WAB attribute table

686
8
05-14-2019 09:12 AM
AhnaMiller2
Occasional Contributor

Hi All, I have a calculated field expression in a hosted feature layer and when I attempt to export to CSV from a WAB attribute table, the CSV comes up blank in this calculated field. Is this expected behavior?

Some screenshots below to help depict the issue I am finding

It shows up in the map pop up and the attribute table without issue:

I have created a web app using web app builder and the attribute table widget still shows this calculation

However, when i go to "export to CSV" from the WAB Attribute table widget, the CSV comes up with a blank value

8 Replies
XanderBakker
Esri Esteemed Contributor

Question; did you do a real Field Calculation or did you define the Arcade expression in the pop-up window?

0 Kudos
AhnaMiller2
Occasional Contributor

Hi Xander, I defined an arcade expression in the pop up window

0 Kudos
XanderBakker
Esri Esteemed Contributor

In that case it has limitations. You will not be able to use this "virtual field" in many widgets and as you noticed it will not end up in the exported (although it is strange that the field name does appear in the export).

JasonMatney
New Contributor III

Xander - thanks for the reply. 

What would you recommend for an alternative for exporting custom fields from Web AppBuilder? 

I would like to allow users to create polygons in a WAB app using the edit widget. 

Then I would like these user-created polygons to have fields that auto-populate (as is possible with Arcade virtual fields)

Then I would like the user to be able to export the results, either as a shapefile or as a csv, and retain the auto-populated fields.

Is this possible?

Thanks!

XanderBakker
Esri Esteemed Contributor

Hi jamatney , I don't think it is possible with only configuration of some Arcade expressions, but I do think it would be a good feature to have that these virtual fields end up in the export. You will probably have to do some development (WAB dev edition) to make the schema changes and force the values into the export.

JasonMatney
New Contributor III

Ahna - how did you end up solving this problem? 

Thank you!

0 Kudos
AhnaMiller2
Occasional Contributor

Sorry to say I have not yet found one. Hopefully this will be accounted for in a future build

MarcGraham2
Occasional Contributor II

Hi,

If this is in ArcGIS Enterprise and the data is stored in an Enterprise Geodatabase you could try using attribute rules: Introduction to attribute rules—Geodatabases | ArcGIS Desktop 

Cheers,

Marc

0 Kudos