Route doesn't match streets

1315
3
04-16-2012 11:07 AM
Highlighted
by
New Contributor II
Hello all;

I have my own streets layer which I created a network analysis of, everything works great except the resulting route graphic doesn't match the streets in areas where there is high curvature, please see attached image.
You can do this yourself by going to http://www.digitaleg.com/Digital_Egypt/El-Rehab/GIS/Rehab.html and click on the car symbol on the top left menu. generate a route and chances are in some areas it will be rugged or not smooth as the street it is supposed to track. Here is also the route layer
http://arcgis2.roktech.net/ArcGIS/rest/services/DigitalEg/Rehab/NAServer/Route

I
am assuming it has nothing to do with the flex code?

Thanks
Raffi
[ATTACH=CONFIG]13558[/ATTACH]
Tags (2)
Reply
0 Kudos
3 Replies
Highlighted
Occasional Contributor
Hi Raffi,

Such effect might be caused by geometry generalization.

Please try setting outputGeometryPrecision on the routeParameters object to zero. If it helps, try slightly increasing it to e.g. 2 meters (outputGeometryPrecision and outputGeometryPrecisionUnits params) - completely ungeneralized geometry can be a big payload.

There is also a Default Output Geometry Precision parameter on the Network Analyst Server itself (in service properties, under Network Analysis capabilities), in case you do not want to pass the above parameters with every request.

Dmitry
Reply
0 Kudos
Highlighted
by
New Contributor II
Hello Dmitry;

Many thanks for your reply. I shall try what you suggested and repost here.
Kind Regards;
Raffi

Hi Raffi,

Such effect might be caused by geometry generalization.

Please try setting outputGeometryPrecision on the routeParameters object to zero. If it helps, try slightly increasing it to e.g. 2 meters (outputGeometryPrecision and outputGeometryPrecisionUnits params) - completely ungeneralized geometry can be a big payload.

There is also a Default Output Geometry Precision parameter on the Network Analyst Server itself (in service properties, under Network Analysis capabilities), in case you do not want to pass the above parameters with every request.

Dmitry
Reply
0 Kudos
Highlighted
by
New Contributor II
Hello Dmitry;

I actually tried both methods to no avail.

In my flex code, I set the outputGeometryPrecision from 0 to 10, one by one, and it makes no difference. I also set the Default Output Geometry Precision in the service properties from 0 to 1 and then 2, and nothing changed again. When I do set Force Hirachy Beyond to any value, the application generates an error.

Here is the route parameters code:

        <esri:RouteParameters id="routeParams" outputGeometryPrecision="0" outputGeometryPrecisionUnits="2"
                              outSpatialReference="{myMap.spatialReference}"
                              pointBarriers="{barriers}"
                              returnDirections="true"
                              directionsLengthUnits="esriKilometers"
                              returnRoutes="false"
                              stops="{stopsFS}"/>

I also tried not setting the outputGeometryPrecisionUnits to anything.
Any help is appreciated. Thanks
Raffi

Hi Raffi,

Such effect might be caused by geometry generalization.

Please try setting outputGeometryPrecision on the routeParameters object to zero. If it helps, try slightly increasing it to e.g. 2 meters (outputGeometryPrecision and outputGeometryPrecisionUnits params) - completely ungeneralized geometry can be a big payload.

There is also a Default Output Geometry Precision parameter on the Network Analyst Server itself (in service properties, under Network Analysis capabilities), in case you do not want to pass the above parameters with every request.

Dmitry
Reply
0 Kudos