OD Cost Matrix Distance Accumulation Issues - Network Analyst 9.2

124
4
03-17-2011 07:55 PM
Highlighted
New Contributor
Hi All,

I am just wondering if anyone has experienced any distance accumulation issues in the resulting dbf distance file when undertaking a OD Cost Matrix with the use of NA in ArcGIS 9.2??

I am basically running a OD Cost matrix and NA repeatedly accumulates all the distances incorrectly. I have a number of road class types described within my network dataset that are required to be accumulated.

I have rebuilt the network a number of times, and also restarted ArcGIS several times however the issue persists. This is an issue that has only begun to occur recently, and does not occur on older network datasets that had been created with 9.2.

Has anyone possibly experienced this and know of a solution?

Any assistance would be greatly appreciated.
Tags (2)
Reply
0 Kudos
4 Replies
Highlighted
Esri Regular Contributor
To help narrow down the problem, create a route analysis layer and turn on the accumulations as in the OD Cost matrix and run a path between two known locations and examine the accumulations. Do they appear right? Alternatively you can use the Network Identify button (second from right on the NA toolbar) and click on a network edge and examine the values of the impedances that you are accumulating. Do they appear to be correct?

Jay Sandhu
Reply
0 Kudos
Highlighted
New Contributor
To help narrow down the problem, create a route analysis layer and turn on the accumulations as in the OD Cost matrix and run a path between two known locations and examine the accumulations. Do they appear right? Alternatively you can use the Network Identify button (second from right on the NA toolbar) and click on a network edge and examine the values of the impedances that you are accumulating. Do they appear to be correct?

Jay Sandhu


Thanks alot for your trouble shooting suggestions Jay.

I have undertaken a few runs using the shortest route method, and NA does accumulate the distances correctly using this.

Do you think I am trying to accumulate to many distances at once with the OD Cost Matrix?  I am currently attempting to do 400 odd origins to 50 odd destinations, and NA 9.2 has completed this successfully in the past, accumulating the various road class distances correctly. So essentially I am still at a loss as to what is going on with the OD Cost Matrix in NA 9.2??

Do you possibly have any further suggestions?  Any assistance would be gratefully appreciated.
Reply
0 Kudos
Highlighted
Esri Regular Contributor
A 400 to 50 OD is not large for the OD solver. So that should not be an issue.

Can you give an example of what you are solving on (time) and accumulating on?
And examples of the values coming back and what you were expecting?

Perhpahs another thing you can do is to run the Closest Facility Solver. Here you map the Origins as Incidents and Destinations. Set to solve for all 50 facilities and turn on the accumulations. You should get the same results as the OD. Now if the accumulations are wrong, you can inspect the associated "route" for that OD pair and see/add up the individual edge values to see why/where the accumulations are wrong or perhaps that will pinpoint some bad data.

Regards,
Jay Sandhu
Reply
0 Kudos
Highlighted
New Contributor
Thanks a lot for your suggestions again Jay.

The cost impedance I am attempting to accumulate with the OD Cost matirx is distance in kilometers.

Essentially I have 4 different road classes, which a different distance factor applies to each segment of rad class, for example:

A Class = distance(km)*1  = 10km
B Class = Distance(km)*1.25 = 2km
C Class  = Distance * 2  = 4km
Length = whish is the geometric length of the segment (km)

Essentially the output w should be

A = 10km
B = 2.5km
C = 8km
Length = 16km

The resulting attributes have in the past accumlated the distances correctly but I am still at a loss as to why they are not now.

After undertaking the same process using the Closest facility option with the same networjk dataset, the distances accumlate correctly! I guess this is a solution to the problem, however if you have any ideas as to why the OD cost matrix may not be accumulating correctly please let me know.

Thanks again Jay!
Reply
0 Kudos