Network Analyst VRP 2 errors and solution without a route

4293
3
01-28-2015 08:08 PM
Highlighted
New Contributor II

Hello,

I am trying to solve a vehicle routing problem and the Network Analyst shows two errors.

Error: "Failure while working with internal route problem instance"

Error: "A column was specified that does not exist."

After clicking solve the algorithm runs well. I have outputs in route properties, but there is no route on the map. I can see only the sequence of orders.

 

I found this thread here:

Network Analyst Bus Routing

 

And If I set the output shape to None, no error appears but still cannot see the route (only for "straight line" it connects the nodes according the sequence, but that has nothing to do with road network). In the attribute table there is "OK" for all fields in "Status" column and "Null" for all "ViolatedConstrains".

 

I am using Desktop Arc GIS 10.1

I welcome any help, recommendations or tips what to do or what these errors could mean.

 

Thank you.

 

Karel

3 Replies
Highlighted
New Contributor II

In the end there was an error in the name of my cost attributes. It wasn't in the attribute table but in the Network Dataset Properties, Attributes tab.

Reply
0 Kudos
Highlighted
New Contributor II

Do you mind elaborating on the solution to this error a little more? I am having a similar error come up. The orders are being assigned sequences but I need the route geometry to be made.

Which name in your cost attributes had an error?

Thanks

Reply
0 Kudos
Highlighted
New Contributor III

I had this error. When I took the space out of the cost attribute name it fixed it.

Reply
0 Kudos