Network analyst Load locations tool problem

6377
10
Jump to solution
07-08-2015 03:48 AM
MarinaGladkova
New Contributor

Hello everybody! I work on the university computer with ArcGIS 10.2.2. I've encountered some problem with Network analyst. My aim is to build service areas around polygons. I try to load polygons with "Load Locations" tool. In the instruction from the webpage ( http://webhelp.esri.com/arcgisdesktop/9.3/index.cfm?TopicName=Adding_network_analysis_objects_to_net...) it's written, that it is possible (here I attach the screenshot from the instruction). But in my case there is the mistake (attached as mistake.png). Could you please possibly say what is wrong here and how can I adjust my polygon data in order to be recognised and added as a network facility? Thank you very much in advance!


  instruction.png

load_locations_window.png

mistake.png

Best regards,

Marina Gladkova

0 Kudos
10 Replies
MTCGIS
by
New Contributor II

I encountered this issue as well in ArcGIS 10.3.1 While the Help documentation for Facilities Classes and Fields does not explicitly say only the point geometry type can be loaded, the Load Locations UI still allows selection of non-point geometry types. Furthermore, there is a check box underneath that restricts the drop down to only point layers, which implies that non-point geometries are valid locations.

Both the documentation and UI should explicitly express application logic. The error message says "the input features must have the correct geometry type". The documentation should state the "correct geometry type".

0 Kudos