Network analysis: Route: Create fastest route with shape_length

348
6
04-28-2021 04:45 AM
Labels (1)
Zaki
by
New Contributor II

I have a feature class with Shape_length and roadcategories "E" = europeway, "F"  Highway and so on. 

I try to do my analysis in ModelBuilder. 

step 1: Add new attribute field (Speed_limit)

step 2: Calculate field (E = 100km/h, F = 80km/h and so on).

step 3: Add field (Time used per line)

step 4: ((shape_length/1000)/Speed_limit)*60

After that i make a feature dataset and then a network dataset and "build network" in the modelbuilder. When i am finished i am able to find the shortest way from A to B, but not the fastest way. I see that i can do some stuff in network dataset properties, but i am still not able to find the fastest way.

Does anyone know what i am doing wrong? 

I have uploaded a picture of the modelbuilder and a picture of properties under det network dataset. 

0 Kudos
6 Replies
DanPatterson
MVP Honored Contributor

What were you network analyst "costs" set to?

Cost attributes—ArcGIS Pro | Documentation


... sort of retired...
0 Kudos
Zaki
by
New Contributor II

does this picture answer the question?

0 Kudos
DanPatterson
MVP Honored Contributor

Did you read the link about Delete so you can use another cost attribute?


... sort of retired...
0 Kudos
Zaki
by
New Contributor II

No havent read anything about Delete so you can use another cost attribute. Where do i find that?

0 Kudos
DanPatterson
MVP Honored Contributor

Network elements—ArcGIS Pro | Documentation

There is a whole table of contents to left in the link above.  It describes how to set up your network analysis

More generally, the whole network analyst extension and its options begins in this link

What is the ArcGIS Network Analyst extension?—ArcGIS Pro | Documentation

and there are even tutorials.

The help topics are excellent.


... sort of retired...
0 Kudos
Zaki
by
New Contributor II

I have tried to "build network" again after changing the cost type. and now i get output of TIME and a faster route than precious, but the time on the route shows 1509 but the time should be like 10 minutes. what can be the problem? 

0 Kudos