Can't find route when there are overlapping lines (which are valid)

1314
4
02-06-2012 06:35 AM
Highlighted
New Contributor
I've constructed a network with overlapping lines - but the overlapping lines belong to different connectivity groups.
When I was testing the network - I realised that a route that I know is valid and should be identified - is not identied and in fact I get an error message that reads "Warning no route for locaton X to locatio Y".
It is only when I place the stop on a section with overlapping lines that I get the problem - but I didn't expect this to happed as they are part of different connectivity groups and the lines reflec the entire route - which network analysis returns an error for.
I have attached the network and map if anyone is interesting in having a look at this problem. I would greatly appreciate any feedback.
Kind regards
Jacqueline
Tags (2)
Reply
0 Kudos
4 Replies
Highlighted
Esri Regular Contributor
Most likely you have connectivity issues. To check that, create a service area solver and bring up its properties. On the Line Generation tab, turn on Generate Lines and on the Polygon Generation tab, turn off Generate Polygons. Now place a facility location where you have your first stop in the route and solve. It will show where the connectivity issues occur.

Jay Sandhu
Reply
0 Kudos
Highlighted
Esri Contributor
I took a quick look at your mxd. It appears there are several one-way restrictions that are making the route to the stops you have infeasible. If you turn off the Oneway restriction on the route layer, you'll get a solution. It may help you to visualize the oneways (see the section entitled Symbolizing restrictions with arrows).

Another point to consider is you can more precisely choose which edges your stops locate on by setting up a query (here's a link to the help) before adding the stops to the route layer. It may be that you want to locate on one overlapping edge, but not the other; in this case, the query definition will help. I tried this and located Stop 2 stop on PathLine_0, instead of PathLine_1, and got a route, even with the one-way restriction enabled.

Robert
Reply
0 Kudos
Highlighted
New Contributor
Thank you so much for your suggestions Robert and Jay - I really appreciate your time.

In response:
All of the lines do have one way restrictions and these have been double checked and they are correct. Even with the one way restrictions there is a valid path between the stops.
I did a service area solver and it doesn't highlight the line that stop 2 is on - but it should!

In response to the suggestion by Robert - I'm using ArcGIS 9.3.1. and when I go to the route layer properties - in the Finding Network Locations - if I unselect all the lines except the line I know the stop is on - then YES it does find a route ! (which is progress! - so Thank you very much).
But then when I switch them all on again - it doesn't find a route.

I suspect that when all the lines are ticked in the 'Finding Network Locations' it tries to locate the stop on either the 'First' or 'Closest' - but I don't understand how this works when the lines are actually overlapping over portions of the line.

What I'd like it to do is just find the route using whichever line makes the route possible - but it doesn't seem to like this and comes up with the error. (Unless as mentioned above I untick all the lines except the one that I know would solve the route).

Do you have suggestions for how I can ask it to find the route when there are partially overlapping lines like this? (Is there a query I can build to make it consider all the lines? not just the first, but all overlapped lines?)

Many many thanks.
I really appreciate your help.


PS. I am using ArcGIS 9.3.1.
Reply
0 Kudos
Highlighted
New Contributor
Hi Again,
I've created a diagram to illustrate my problem (attached as JPG).
Lines 1 and 2 overlap from the point labelled Y to Node C.

My problem is that I want Network analyst to identify the route from Node B to Node C. This is clearly possible by travelling along Line 1.

When I try to get a route from Node B to point X on Line 1 - a route is found.
When I try to get a route from Node B to point Y (which lies on a section of the network with 2 overlapping lines) no route is found.
When I try to get a route from Node B to Node C - no route is found.

Using the suggestion by Robert - I can achieve a route from Node B to Node C but only if I use the Route Layer Properties > Network Location  > Finding Network Locations and select the Lines I know the route should use (make sure the overlapping line which should not be used is not selected), but this is not viable because ultimately I want to use the network to solve a more complex problem where this same issue may occurr further down the netowork and I won't know beforehand which line in the overlapping sections should be used to solve the problem.

Does anyone have any suggestions as to how this can be achieved?
(In my first post I have included the actual network as I have built it).

I would really appreciate any feedback - I'm really stuck on this.
Many thanks in advance.
Jacqueline
Reply
0 Kudos