Add GTFS to a Network Dataset only generates a walking service area

2312
1
12-19-2013 10:35 AM
Highlighted
New Contributor
I'm using the Add GTFS to a Network Dataset toolpak to do some transit-based accessibility analysis. Basically, I'm trying to generate service area polygons from a set of "home" census blocks to determine precisely which other census blocks can be reached in 45 minutes of pedestrian+transit travel. Everything seems to be going fine until I solve my service area analysis layer: it solves, but generates a set of polygons that only appear to cover the distance one could walk in 45 minutes. It appears not to include the transit system at all.

Ideas? Is there a way to check if this is actually what's happening?

Thanks!
Tags (2)
Reply
0 Kudos
1 Reply
Highlighted
Esri Regular Contributor
Here are a few things to check:

- Did you select "Use Time" and choose a time of day for your analysis?  The transit part of the network won't be used if you don't select a time of day.

- If you're using specific dates, does your date fall within the date range of the GTFS data?  Open the calendar.txt file to see the date ranges covered by your GTFS data.

- Did you remember to run Step 4 of the tool (Get EIDs)?

- Did you rebuild the network after you ran Step 4?  If so, you will need to run Step 4 again.

- Did you set up your evaluators correctly (see the user's manual)

- When you made your network, did you use Override for the connectivity policy on the Stops_Snapped2Streets?  These stops will connect to vertices in the streets.  If your streets have End Point for connectivity and you don't select Override for Stops_Snapped2Streets, they don't actually be connected in the network.  Note: If you change this, you will have to rebuild your network and run Step 4 again.

Here's how I usually debug transit problems:
- Zoom in to a single transit line.
- Create a new route layer and add stops on the street near each end of that transit line.
- Use Network Identify to get the SourceOID or EID of that transit line.
- Open TransitScheduleTable and search for that SourceOID or EID.  You'll find a start time when this edge should be traversable
- Set your route layer's start time to a time just before the time when the edge should be traversed and solve the route layer.
- Check to see if it uses the transit line instead of the street.  You might have to adjust the start time.  Check all the minutes surrounding your expected start time. If it never uses the transit lines, something is probably wrong with your network.

After you've checked all the things I mentioned above, if it's still not working, you can post your data, and I'd be happy to take a look at it.