EgdbSQL connection failure

728
7
Jump to solution
07-19-2019 01:30 PM
deleted-user-H23pxZFaj1tR
New Contributor III

Using the GUI method, I am configuring the extension EgdbSQL to make a connection file.  The process fail the Test with the following message:

SUCCESS: Connecting user (dbo) is  the owner of the eGDB (dbo), and they have the 'VIEW SERVER STATE' server privilege. 
FAILURE: Microsoft System CLR Types for Microsoft SQL Server does not appear to be functioning on this machine.  Please ensure that this feature is installed (e.g. https://www.microsoft.com/en-us/download/details.aspx?id=29065)

On the ArcGIS Monitor machine, I installed the SQLSysClrTypes.msi for SQL Server 2017, but I get the same message.  Reinstalled SQLSysClrTypes.msi as Administrator at cmd line.  No change.

EgdbSQL configuration window with error that System CLR Types is not installed, shown over Control Panel Programs showing installed System CLR Types.

Any ideas?

Tags (2)
0 Kudos
1 Solution

Accepted Solutions
MikeSchonlau
Occasional Contributor II

I ran into the same problem and had success adding this line to my connection string:

Type System Version=Latest;

I am also using SQL Server 2017. Just using this string (Type System Version=SQL Server 2017) didn't work for me.

View solution in original post

7 Replies
JohnGraham2
Occasional Contributor

Hi David,

In the EgdbSQL_Readme, the troubleshooting section suggests to add a line to your connection string (located in C:\ArcGIS Monitor\Administrator\resources\app\bin\EgdbSQL\sqlserver) about the CLR Type, for example:

;Type System Version=SQL Server 2017

Hope it helps. If you need more assistance with the EgdbSQL extension, Esri Professional Services offers consulting support.

Best Regards, 

John

MikeSchonlau
Occasional Contributor II

I ran into the same problem and had success adding this line to my connection string:

Type System Version=Latest;

I am also using SQL Server 2017. Just using this string (Type System Version=SQL Server 2017) didn't work for me.

deleted-user-H23pxZFaj1tR
New Contributor III

Type System Version=SQL Server 2017 did not work for me either.  I had used Type System Version=SQL Server 2012, which worked with the 2017 software, but Latest seems more appropriate.

0 Kudos
Jamie_Lau
New Contributor

Hi, 
I am working with SQL Server 2017 as well and installed the SQLSysClrTypes.msi for that.  My question is regarding the change to the connectionString. (System Version=Latest). That capability is greyed out on the interface. I went ahead and tried to edit the connection string file directly at C:\ArcGIS Monitor\Administrator\resources\app\bin\EgdbSQL\sqlserver, but that had no effect either.  How do I get it to read the connectionString with this edit?

0 Kudos
Jamie_Lau
New Contributor

Hi, 
I am working with SQL Server 2017 as well and installed the SQLSysClrTypes.msi for that.  My question is regarding the change to the connectionString. (System Version=Latest). That capability is greyed out on the interface. I went ahead and tried to edit the connection string file directly at C:\ArcGIS Monitor\Administrator\resources\app\bin\EgdbSQL\sqlserver, but that had no effect either.  How do I get it to read the connectionString with this edit?

0 Kudos
User35489
Occasional Contributor III

Hi,

I faced the same issue and got it resolved.
Kindly try option 3 given in the readme document with the application. It worked for me.

0 Kudos
Jamie_Lau
New Contributor

Thank you. It did get further using Option 3, but now receiving this error:
ERROR: There is already an open DataReader associated with this Command which must be closed first.

Tried adding "Type System Version=Latest" and "Type System Version= SQL Server 2012" but still receiving same error. It wouldn't run at all with "Type System Version=SQL Server 2017"

0 Kudos