Select to view content in your preferred language

ArcGIS Monitor Excel Report does not generate report

612
3
05-26-2023 01:27 PM
EdnaKanazawa
New Contributor II

We are generating the report using ArcGIS Monitor Excel Report, but it is generating the error below

2023-05-26 16:52:58.776511 service,Request Response Time Avg,svcRTAvg
'features'
Traceback (most recent call last):
File "ExcelReport.py", line 11, in main
File "modules\report_builder.py", line 24, in __init__
File "modules\Wkb\wkb_builder.py", line 36, in __init__
File "modules\AGM_API\collection.py", line 154, in metric_stats_by_name
KeyError: 'features'
None
Traceback (most recent call last):
File "ExcelReport.py", line 11, in main
File "modules\report_builder.py", line 24, in __init__
File "modules\Wkb\wkb_builder.py", line 36, in __init__
File "modules\AGM_API\collection.py", line 154, in metric_stats_by_name
KeyError: 'features'

Tags (1)
0 Kudos
3 Replies
AndrewSakowicz
Esri Contributor

@EdnaKanazawa  Do you have arcgis server service in the collection specified in the SampleConfig.json?  Note, you can remove types as needed, see below 

AndrewSakowicz_0-1685141283519.png

 

EdnaKanazawa
New Contributor II

Yes, I have one portal, server and host @AndrewSakowicz 

0 Kudos
AndrewSakowicz
Esri Contributor

Thanks @EdnaKanazawa Can you verify that you have this metric (request response time) in one of you your services?  Also, can you test removing "service" from types.  If this does not provide clues, l'll contact you directly to troubleshoot this.

AndrewSakowicz_0-1685142281357.png