Layer masking keeps referencing old masking layer

218
2
01-10-2019 05:02 PM
Labels (1)
CharlottePeters2
New Contributor III

Hi,

I'm working with layer masking in ArcMap 10.6 and having issues getting ArcMap to recognizes my layer masking changes. I created a feature outline mask from an annotation layer (not feature-linked) stored in a FGDB. I enabled layer masking and masking work correctly. I had to move a label in the annotation layer, but created a new feature outline mask to reflect the updated annotation layer. I removed the old mask from the project, but when I try to enable layer masking using the new mask, the map still masks using the old mask.

I've tried:

  • turning layer masking on/off
  • clearing ArcMap's display cache
  • deleting files from the Windows TEMP folder
  • rebooting ArcMap and the computer

Any ideas on how to get ArcMap to recognize the new layer mask?

Thanks.

0 Kudos
2 Replies
CharlottePeters2
New Contributor III

After some more troubleshooting, I figured out the masking issue. Even though I removed the old mask from my project, it was still in my FGDB along with the new mask. When I deleted the old mask from the FGDB, the layer masking worked correctly using the new mask. I'm guessing that for layer masking purposes, only one mask can exist for an annotation layer in the GDB.

Cheers.

BrianHall1
New Contributor III

Thank you very much.  Your solution worked for me too.

0 Kudos