Conneect AIS to AIXM 5.1 database

2602
4
02-19-2014 12:17 AM
New Contributor II
Hi!
I have a ArcGIS 10.2 for Aviation Charting license and I have AIS geobatabase (SQL Server Express) in my PC also i have Comsoft
AIXM 5.1 database.

I'm intresting how I connect my AIS to AIXM 5.1 database.
Halpe me, please!
Reply
0 Kudos
4 Replies
New Contributor II
Hey Tornike,

The ideal way to populate your AIS data with valid AIXM 5.1 data is to ingest a valid AIXM 5.1 message using the Import AIXM 5.1 to AIS ETL tool.  Import AIXM 5.1 to AIS tool requires an Esri Data Interoperability extension license or a stand alone Safe Software FME license to utilize the tool.  Here is a link to the online documentation for the tool http://resources.arcgis.com/en/help/main/10.2/index.html#//02960000000p000000.

We are not very familiar with Comsoft products, but we assume you should be able to generate a valid AIXM 5.1 message from your existing database.  Once you have the message, you use it as input for the tool and the output will be the AIS database you have in SQL Express.
Reply
0 Kudos
New Contributor II
Thanks to advise!
Can I connect Comsoft AIXM 5.1 database server to AIS (SQL Server EXpress) whit WFS 2.0 (Web Feature Service)?
I know that Interoperability Connections tools worked WFS 1.0 and WFS 1.1 versions.
I don't known very good what is a Web Feature Service and how it's working and maybe I asked you wron questan.
Help me, please!
Reply
0 Kudos
New Contributor II
Hey Tornike,

Unfortunately, even using WFS, the schemas between your Comsoft database and AIS database will be different.  The Import AIXM 5.1 to AIS takes the industry AIXM standard message and translates it into the AIS geodatabase schema. 

We are currently researching WFS as an input to our data exchange tools but no release date has been agreed upon. 

WFS 2.0 support within ArcGIS is currently planned for the next major release.
Reply
0 Kudos
New Contributor II
ok, thanks!!
Reply
0 Kudos