Instant App attachment viewer error

1319
15
08-14-2023 12:12 PM
Labels (1)
Sam_Armstrong
New Contributor

Hello, 

I am attempting to fix this Instant App issue. When a user clicks on a point feature, the corresponding attribute information is supposed to display on the attachment window on the left hand side of the app window.

After a user clicks through a few points, the attachment window will begin to present incorrect and mixed information: The bold point feature title at the top of the attachment window text box is always correct, but the rest of the attribute information below still shows the previous point's attribute information for some reason. But, the attribute information will update to the correct information when I zoom into the map much more closely. I also noticed that this issue does not present in configuration when I have the same instant app configured as attachment-focused instead of map-focused.

Has anyone else seen this same error before on a different Instant App? I am wondering if this is a data related error on my end or if this a bug. Please see the image below. Thank you for any insight! 

 

(This image shows the above described error. The user previously selected point 43, but is now currently selecting point 29. However, the attribute information on the text box on the left hand side is still showing the attribute information from the previous selection.)

question3.png

15 Replies
SarahMcDonald_Esri
Esri Contributor

Hi @Sam_Armstrong,

Thanks for posting about this issue. The team is aware of the problem and is looking into it. 

Thanks!

Sarah

0 Kudos
mwebs23
New Contributor

I have high profile public-facing solution that uses this app and exhibits the same issue(s). Any idea when this bug will be fixed? Thanks.

PanagiotisDimopoulos
New Contributor

Hi @Sam_Armstrong,
Ran into the same issue today. I haven't been able to find a workaround. I tried messing with the layer's indexing (seemed reasonable) but without success. 

ZacharyUhlmann1
Occasional Contributor III

Same boat.  [redacted criticism]. Would love to make it 3 days without some software issue in the ESRI universe...

0 Kudos
ShanaCrosson2
New Contributor III

I was just going to come post about this issue. I've built probably 100 Attachment viewer apps, but never had this problem until the last three weeks. If anyone has fixes or workarounds, I'd love to hear it.

0 Kudos
sblazeycov
New Contributor III

Yes, I just came here to see if anyone else had reported this.  We also have a map focused attachment viewer and we are seeing the exact same error/bug you describe.

0 Kudos
SarahMcDonald_Esri
Esri Contributor

Hi all, 

Thanks for your patience on this one. The issue should be resolved now. Let me know if anyone is still seeing any issues with pop-up information sticking around still. 

Thanks!

Sarah

0 Kudos
sblazeycov
New Contributor III

Thanks Sarah!  I had switched our Attachment Viewer from Map Focused to Attachment Focused while this issue was worked on.  I saw your update so I just switched it back from Attachment Focused to Map Focused, and unfortunately I still see the issue with pop-up information sticking around on the Map Focused one.

0 Kudos
SarahMcDonald_Esri
Esri Contributor

Hi @sblazeycov 

Would it be possible to share your app with me? 

Thanks!

Sarah

0 Kudos