Basic Viewer toolbar will not close

363
7
06-09-2020 12:28 PM
LindseyStone
Occasional Contributor III

I built a Web App using the Basic Viewer in ArcGIS Online.  I have added the legend tool to the toolbar.  However, what I have noticed is once that tool is opened the end user can't close it.  I have tried this with one to several tools on the toolbar.  You can switch between the tools but you can not close them.  The problem I see with this is when you are on a 8" or 10" phone that tool takes up a lot real estate on the screen and map.  On the Web AppBuilder applications, once you open a tool you can close them by clicking an X or by clicking the button again.  Is this a bug with the Basic Viewer or something that has been an oversight and needs to be placed as a feature request?

0 Kudos
7 Replies
KristaMcPherson
Esri Contributor

Hello Lindsey, thank you for reaching out about this issue. I created at app with the settings in the screenshot you provided. I was not able to reproduce this issue and I was able to close the Legend tool. Can you confirm if you are currently able to reproduce this behavior?

0 Kudos
LindseyStone
Occasional Contributor III

Krista,

This is the link to the App that is producing this problem.  As you can see the legend automatically opens, but if I click the legend button in never closes.

https://hastingsne.maps.arcgis.com/apps/View/index.html?appid=5ffb7acb0d9f45abad3af7daf4ec3483

0 Kudos
KristaMcPherson
Esri Contributor

Hi Lindsey, Thank you for following up on this. I understand the issue you are seeing now with this app. Can you confirm if your app has any custom layout options configured under the Theme tab?

0 Kudos
LindseyStone
Occasional Contributor III

Here is a screen shot of the theme tab.

0 Kudos
KristaMcPherson
Esri Contributor

Thank you for providing the screenshot. I am able to reproduce the same behavior when the Layout option is set to Menu Bar. All other layout options allow the end user to open and close the Legend. Would it be possible to update your app to use one of the other layout option?

0 Kudos
LindseyStone
Occasional Contributor III

I suppose I could.  Is this a bug then?  Because it really seems like a bug.

0 Kudos
KristaMcPherson
Esri Contributor

Hi Lindsey, I have confirmed that this is an issue that needs to be fixed and I will report it as such. In the meantime, I see that you have already updated the settings in your current app as a workaround. I would also like to suggest the Media Map or Minimalist app templates as potential alternatives.

Here is an example of what your data would look like in the Minimalist app: https://www.arcgis.com/apps/instant/minimalist/index.html?appid=d54a6072bb0a4a2da1a96b07540ed7e3 

0 Kudos