Reservation Layer Meeting Rooms

287
6
Jump to solution
11-29-2021 10:06 AM
AlistairM
Esri Contributor

Hello, I am trying to configure Meeting Rooms in the Indoors Viewer app (ArcGIS Enterprise 10.9.1). My Indoors database was created with the latest version of Pro and has the Reservations feature class included and also the Units FC has the reservation_method field associated with the DOM_RESERVATION_METHOD domain. The reservations layer is published as an editable feature layer. I have calculated the reservation_method field so that bookable units have a value of 1 (showing description "Reservable") and vice versa for non-bookable units. My data is in an enterprise geodatabase and published as a feature service (for use in Space Planner) which is what is included in the web map.

The Indoors Viewer app automatically detects the Reservations layer and the tick boxes for hotels and meeting rooms are both on by default. From the docs, "If all the prerequisites are met in the web map, the Meeting rooms check box is automatically checked." It seems like it's picking up the field on the Units but in the Viewer app I'm only getting a quick access button for hotels but not for meeting rooms:

AlistairM_0-1638206080853.png

Anyone seen this before or have any suggestions? Thanks in advance!    

0 Kudos
1 Solution

Accepted Solutions
FarazSiddiqui
Esri Contributor

Hi @AlistairM There is an issue with meeting that it only appears when there is at least one hotel unit. We have resolved the issue and it will be avaible in the next release of ArcGIS Online and Enterprise. As a work around, in Indoors Space Planner please create a hotel and assign a unit to the hotel and merge your plan. Refresh the Indoors Viewer and verify the meeting button. Please let us know if you still have any issues.

View solution in original post

6 Replies
Jinho_Kang
New Contributor II

Hi there.

Do you have a mobile map (Android or iOS) running with the reservation layer by any chance?
If so, do you see the meeting room icon next to a hotel icon?

Thanks.

 

0 Kudos
AlistairM
Esri Contributor

Hello, thanks for the quick reply. I am currently working against a development Portal which is not accessible outside my company network and I do not have a VPN on my phone so can't test this unfortunately but the suggestion from Faraz below seems to have worked.

FarazSiddiqui
Esri Contributor

Hi @AlistairM There is an issue with meeting that it only appears when there is at least one hotel unit. We have resolved the issue and it will be avaible in the next release of ArcGIS Online and Enterprise. As a work around, in Indoors Space Planner please create a hotel and assign a unit to the hotel and merge your plan. Refresh the Indoors Viewer and verify the meeting button. Please let us know if you still have any issues.

AlistairM
Esri Contributor

Thanks Faraz, strangely in Space Planner the option to merge my plan (both plan>DEFAULT and the other way around) are both greyed out. Any idea why this might be? I have all the same data and configuration in a 10.8.1 deployment and have been able to merge plans successfully.

I manually reconciled and posted the version in Pro though and I can now see the meeting button in the viewer app so your suggestion has done the trick.

0 Kudos
FarazSiddiqui
Esri Contributor

@AlistairM Could you please share a screenshot of the Space Planner where you see options greyed out?

0 Kudos
AlistairM
Esri Contributor

Ah never mind, my system is just being a bit slow. After 5-10 seconds I get the option to merge. Thanks for your help! 

0 Kudos