"View DataTable" does not work for datasets that are based on a join

326
4
06-04-2021 02:00 PM
JenniferSherry
New Contributor III

Hello, I have noticed that since the updates to ArcGIS Hub were released, for at least two datasets on our Open Data/Hub site, the "view table" option no longer works. 

https://open-data.bouldercolorado.gov/datasets/d7ad8e150c164c32ab1690658f3fa662_4/explore?location=4...

Source: https://maps.bouldercolorado.gov/arcgis2/rest/services/osmp/TrailsNEW/MapServer/4

https://open-data.bouldercolorado.gov/datasets/800684cdaf50432a988b1f3ee763a13a_3/explore?location=4...

Source: https://maps.bouldercolorado.gov/arcgis2/rest/services/osmp/Property/MapServer/3

I was able pinpoint that for these two data layers, published from our ArcGIS Server, each contains a join in the data.  Interestingly, the tables appear just fine in the AGOL items:

https://boulder.maps.arcgis.com/home/item.html?id=d7ad8e150c164c32ab1690658f3fa662#data

https://boulder.maps.arcgis.com/home/item.html?id=800684cdaf50432a988b1f3ee763a13a#data

I could probably resolve this by creating spatial views to publish the feature layers from, but I'm also thinking this is a bug that needs addressed.

Thanks in advance for any advice or helpl you can offer!

Jennifer

0 Kudos
4 Replies
PatrickHammons1
Esri Contributor

Thanks for reaching out, Jennifer. I'm not seeing any obvious reason why the tables aren't loading, so we will need to investigate further. I'll reach out if we need any further info.

0 Kudos
JenniferSherry
New Contributor III

I have an update, but we are still basically having the same issue.  I tried removing/unsharing the dataset from our Hub content libary and also removed public sharing.  When I reapplied the sharing that enables the item to be part of the Hub, I am able now able to see only the column names, but still not the attributes:

https://open-data.bouldercolorado.gov/datasets/d7ad8e150c164c32ab1690658f3fa662_4/explore?location=4...

Any updates on why these tables (that are based on joins) are not showing up?

Thanks-

Jennifer

0 Kudos
PatrickHammons1
Esri Contributor

We're still investigating the cause and will be working on a fix that we expect to be out next week. I will report back if that timeline changes.

0 Kudos
PatrickHammons1
Esri Contributor

We've released an update today that should fix the reported issue, but in the course of QAing we discovered an additional bug with sorting. We're working on a fix and plan to release as soon as it's ready.

0 Kudos