How can I change the Data Download potential of HUB

326
8
02-19-2020 04:47 AM
Highlighted
New Contributor II

Hi, 

I have been tinkering with HUB over the last while with the view to have HUB manage Public access to my data and services, however along the way (early on) I have issues with the restrictions and process around the data access and extraction/download.  So I have a question or observation - or several that I hope somebody can shed light onto and if possible give me direction on how I can use HUB whilst still reaching all my audience in an structured and intuitive fashion.

Currently we have on premise Enterprise and Portal manages the content etc., we have setup collaboration with AGOL from our Portal for content sharing with our HUB site, and all of this is very good, straight forward enough to create and maintain etc. However several  key requirements of our public hub is that all data is accessible and ex-tractable in numerous projections and numerous formats, this is not achievable using HUB.  HUB will delivery standard formats (shape, fgdb etc.) but we want more and we want the user to pick the projection required also - again something that  not supported in HUB(supports wgs84 or native), in addition we need to include in the data download.zip several allied data components that are necessary namely metadata (as txt or xml), style file, license and allied information not contained in the metadata - without these the data is difficult for our users to use the data effectively. So far I've only mentioned vector data and a major component of our datasets are raster, and again unfortunately the HUB product does not deliver on the functionality required in this area. I have pre cooked .zip files with all the attachments I need for the entire dataset downloads however the datasets are National Datasets and require clipping and export to different projections and formats including rasters.

To close the gap we have Interop extension and server  (FME) to potentially have several GP (clip and Ship etc) task's and maps that can be used to fulfill the requirements. So now I'm at the stage of trying to hook up HUB and the non hosted Download options (FME & Maps), and so far its proved impossible to do it smartly.  There are things I'd like HUB to have that it doesn't or at least I haven't found them  - On the Data Details page on HUB its not possible to remove the Download button,( to take the confusion for users out) as Ideally we would like to have a link to the interface that will support multiple projections, formats inc. raster, but the link will be capable of taking parameters from the page such as Dataset Name and extent and any filtering - but at the very least the dataset name would be good. An option is to add links on the Items Description whilst being able to disable the Download button, however I've been unable to create a button object or use and javascript in the  Items Descriptions html editor to pass the extents etc off to my eternal app in an iframe - its strips out all the good stuff!.. Its all I can do on the Item Description element is to have and image (button) that redirects to my app for data extraction - I can add the active layer required by editing the link for the item but I cant capture the map extent or the filtering that the user has applied ... they have to do this again in the data download app which is counter productive. So there is a question here - is there a good way to achieve what I'm looking for here?

To be clear I'd like to continue using the HUB environment, I really like it and it delivers more that the data downloads for me as the collaboration and initiatives environment is the area we are heading for ... but it must be able to deliver the data a bit more effectively for us to be comfortable adoption the HUB approach.

There may be changes on the horizon that cover some of my requirements, if there are I'd love to hear about them.  Likewise if my understanding and approach is incorrect I'd like to know this also before I proceed.    Apologies for teh long winded post and thanks in advance for any guidance / advice.

P

Reply
0 Kudos
8 Replies
Highlighted
Esri Regular Contributor

Try this

  • Enable metadata on your Online organization if you haven't already
  • Edit the metadata for the item you want to list an additional download option for
  • in the "Distributions" section, add a URL to the download resource you want to provide (this link must take you to a file / download)
  • Change the "function" of your distribution to "Download"

This is the result:

Reply
0 Kudos
Highlighted
New Contributor II

Hi Graham

Thanks for the reply  ....  I had seen that instruction on the HUB documentation .... but could not get it working.  However I have since managed to get it working but to get the links showing up I had to set my Organisation Metadata to FGDC format ... Then it worked but the style will be and issue.

However I have noticed an issue .....   while trying this, it may be me but I'd like to understand whats going on better...  

I added an image with a hyperlink in my details / description of my AGOL item and the link is just a test one off to any site for the moment just to see how it presents in HUB.  The image doesn't present well in the search results but does in the details page and the link works.  However if I edit the metadata for the AGOL item to add the additional resources as per your post above .... all the link and image content gets striped from the Item Description in AGOL and the obviously HUB also ..

So my question is two fold - what am I potentially doing wrong to get the result as per your post above with the metadata style of Inspiire and why is my content being stripped from the Item Description ?

can you shed some light of this also  - apologies for using you as support but I've been unable to ensure I'm not missing anything ....  In order to get a spatial filter on the HUB details/downloads page I need to have the data shared public and in wgs84 wm (spherical) with a basemap in th same projection ..... I haven't been able to get any other basemap projection with allied content projection to work ......  the spatial extent download is very useful along with the attribute filter but for our content we would have to convert all  the data  ... any ideas please or pointers to the documentation...

Cheers

Paulg

Reply
0 Kudos
Highlighted
Esri Regular Contributor

My stab in the dark guess as to why you lost your URL when you updated metadata is something fishy happening between multiple browser tabs. That definitely seems odd. I'm going to defer to a colleague on the 2nd question about when we strip out HTML as he knows it better than me!

Reply
0 Kudos
Highlighted
Esri Contributor

Hi Paulg,

Images should work in the item description. Can you send a link to the item you're having issues with?

Thanks,

Patrick

Reply
0 Kudos
Highlighted
New Contributor II

Hi Patrick, 

The Item is @ https://dcenr.maps.arcgis.com/home/item.html?id=a304a02a6bc04d7e8a76bd747b993473 

This is just a test item with test everything... The Icon in the description for this test just links off to https://www.google.ie but i have tried it other links also .....  So this Icon with its link works in AGOL, the metadata has been edited for the 'Additional resources' - under distributor  and shows up  in HUB as I want it .... 

The icon on its own without having a HREF works and doesn't get stripped out, however if I add the HREF in for the image as below 

<div><a href="https://www.google.ie" target="_blank"><img alt="test icon" src="https://dcenr.maps.arcgis.com/sharing/rest/content/items/f21a3c6f8e6c425998500ee2234c9d5a/data" /> </a>
</div>
and save .. it works fine .....  but if I edit the metadata the icon gets stripped out. 

Paulg

Reply
0 Kudos
Highlighted
Esri Contributor

Hmm I'm not able to reproduce the issue. I just added your icon and link to an item and it shows up in the description as expected (Test Item ). I then edited the item description, saved, and the icon and link remained in tact. It's possible that your edits in the description field are breaking the html. Could that be part of the issue?

Reply
0 Kudos
Highlighted
New Contributor II

Hi Patrick 

I dont have access to your test item ....  it could be my edits are breaking the html ...  but I'm only adding the href for the image and nothing else in this test .....

If the link works on your item description then good ... but if you edit the metadata for the item and add the additional resources as described by Graham and save the metadata then for me anyway the href images and link disappear !

Once I have my edits done and I lose the images I can add them back in and they save and are viewable in AGOL and HUB until I re edit/save  the metadata

Attached is the metadata example  - once I save this the ICON is stripped from the description panel

Reply
0 Kudos
Highlighted
Esri Contributor

Ah ok, so when you use the formal metadata editor the html gets stripped. I'm able to reproduce, but unfortunately this appears to be a bug in ArcGIS Online so my team won't be able to get a fix out for you.

We will forward internally, but in the meantime it might be worth posting the issue you're seeing with links and images to the ArcGIS Online‌ community in case others are having a similar problem.

Reply
0 Kudos