Filtered Downloads Not Working

491
7
06-14-2021 02:34 PM
VCGIvanBrown
New Contributor II

Filtered downloads aren't working on our site--period; I found the issue on another site too. First, I filter w/ an attribute query. Next, the preview map displays a subset per the filter. Then, I download a shapefile; the shapefile has all features--not the filtered subset.

I have found this issue to be consistent, whether geometry is line or polygon and whether source service is ArcGIS Online feature layer or ArcGIS Server map-service layer.

Tags (3)
0 Kudos
7 Replies
ThomasHervey1
Esri Contributor

@VCGIvanBrownI'm sorry to hear that you're having this problem. Can you share a link to a problematic example? Also, just to confirm, are you applying a filter (attribute or map) and then enabling the download filter? Below are screenshots where the two toggles are enabled.

 

toggling both a map-based filter and an attribute-based filter

Screen Shot 2021-06-30 at 6.00.50 PM.png

 

toggling a download filter to use map-based filter and an attribute-based filter

Screen Shot 2021-06-30 at 6.02.27 PM.png

0 Kudos
AliciaShyu
New Contributor III

Is there a solution to this? I'm having the same issue. 

After applying the filter and selecting the file type to download the tool just spins for over 10 min without doing anything.download error.png

Without the filter data can be downloaded in every format except "File Geodatabase". I'm getting a "File generation failed" error for that one.

Fail GDB download.png

0 Kudos
ThomasHervey1
Esri Contributor

@AliciaShyuthere are a number of reasons that a download could fail or take longer than expected to generate. Are you the content owner? Would you be able to provide a link to the dataset?

0 Kudos
AliciaShyu
New Contributor III

The organization owns the content and it has been shared to the public. Here's the link to the dataset from our Hub site https://data-desmoines.hub.arcgis.com/datasets/airport-boundary/explore?location=41.641450%2C-93.638... 

0 Kudos
ThomasHervey1
Esri Contributor

Thanks for the details. After running createReplica on the underlying service (which ArcGIS Hub uses for executing downloads), it appears that there's an issue and jobs are failing. This may be due to a server-side configuration but you've found a case where ArcGIS Hub should supply better error messaging. I have added this to the backlog. I suggest that you reach out to Esri Support so that they can walk through the download process and troubleshoot.

0 Kudos
VCGIvanBrown
New Contributor II

I wasn't seeing the Toggle Filters slider under Download Options; it has to be slid to on in order for the filter to be applied to the download. Others weren't seeing it either; finally, someone noticed it and pointed it out. It's there; however, there is something about the page layout that causes it to be missed.

We too get spinning wheels and error messages sometimes with downloads. Are the long-spinning wheels and error messages something seen when the underlying data is from ArcGIS Server (cloud-caching dynamic)? Are these issues reduced/removed by serving data via ArcGIS Online instead?

0 Kudos
ThomasHervey1
Esri Contributor

Thanks, I will incorporate your feedback about the toggles and send it to our design team. The Hub download system can experience issues for a number of reasons. We're currently working on our content management documentation that will help explain the cause and troubleshooting options for the most common download errors.

Depending on the size of the content (i.e., the number of records and the complexity of geometry if present), creating a filtered download can take a long time. This is because the underlying service's createReplica function. The performance of a service's operations is heavily dependent on the underlying ArcGIS Server's machine. Yes, there are typically fewer issues that are easier to diagnose. Also, download times tend to be faster. In most cases we recommend that customers create hosted ArcGIS Online services.

0 Kudos