App from ArcGIS Experience Builder not loaded at ArcGIS Hub Site

252
4
Jump to solution
02-14-2021 06:53 AM
ulrich_kral
New Contributor II

I created an app with ArcGIS Experience Builder and it works quite well at the Experience Builder plattform. Then I switched to ArcGIS Hub, used drag & drop to add a new app and selected the app from the content-library. The app is loaded since two ours without completing the processes. There are just three blue bars moving up and down (see screenshot). I repeated the steps several times, always getting the never ending loop of the three blue bars. Your advise is much appreciated. Thank you.

0 Kudos
2 Solutions

Accepted Solutions
GrahamHudgins
Esri Regular Contributor

check the sharing on the experience....if you want to see it without being logged in then you should make sure it (and any content embedded in the experience) is shared publicly. 

View solution in original post

0 Kudos
ulrich_kral
New Contributor II

The ArcGIS Experience app was already set "public", but the underlaying shape layer not. I have set the shape layer "public" and now it works. Thank you very much, Graham!

View solution in original post

0 Kudos
4 Replies
GrahamHudgins
Esri Regular Contributor

Might be a good idea to check your browser's console to see what's going on. There are security settings in ArcGIS Online that can prevent application embeds from functioning properly. Another possible culprit is private browsing mode which can block embeds across origin....this can depend on your browser's settings. If you need further assistance, I recommend contacting support so they can do some detailed troubleshooting with you.

0 Kudos
ulrich_kral
New Contributor II

Graham, thanks for your help. I switched off the pop-up blocker and the ArcGIS Experience app shows up. Once I log out from the online plattform and visit the public accessible site, the ArcGIS Experince app cannot be seen. Instead the message "www.arcgis.com denied a connection." See screenshots attached. 

0 Kudos
GrahamHudgins
Esri Regular Contributor

check the sharing on the experience....if you want to see it without being logged in then you should make sure it (and any content embedded in the experience) is shared publicly. 

View solution in original post

0 Kudos
ulrich_kral
New Contributor II

The ArcGIS Experience app was already set "public", but the underlaying shape layer not. I have set the shape layer "public" and now it works. Thank you very much, Graham!

View solution in original post

0 Kudos