Spatiotemporal big data store isn't showing up in Geoevent Manager

02-29-2016 01:21 AM
Occasional Contributor

Hi there,

I have configured a spatiotemporal big data store in my test server site.  However it is not showing up in Geoevent manager.

Here is a screenshot if the initial command line config:

spatiotemporal data store command line.PNG

Here is the description from the describedatastore command:

spatiotemporal data store description.PNG

and here is the Data store validation from the Server manager:

data store validation.PNG

So everything looks good, but the Data store is not showing up in Geoevent manager:

I added it to server using the server primary site administrator account before I federated with portal.  I also have a regular data store running on another machine that has been added to portal as the hosting server.  All firewalls are turned off.

Any ideas?



0 Kudos
14 Replies
Esri Regular Contributor

Hey Marc -

Did you try stopping the 'ArcGIS Data Store' service running on the, I'm assuming, Windows machine on which you installed and then enabled the spatiotemporal big data store (vb2stds.c2.test.local)?  In an internal staff training today, a couple of folks were seeing an error logged in GeoEvent ("com.esri.ges.datastore.bds.internal.BDSClientImpl  /  None of the configured ArcGIS Spatiotemporal Big Data Store nodes are available") when trying to create a new output to add features to their BDS.  Restarting the ArcGIS Data Store service fixed their issue.

If you try to browse to http:// vb2stds.c2.test.local:9220 does Elasicsearch respond by asking you to authenticate (provide a username and password) to log-in?  You don't want to connect to Elasticsearch directly over port 9220, but trying to do so might tell you wether or not the service is responding to requests.

Were you able to register and validate a "Portal" type of server connection with GeoEvent as a Data Store?  If GeoEvent does not have a registered server with a recognized BDS the 'ArcGIS Server Connection' dropdown will be empty when trying to configure a GeoEvent output to either add or update features in the spatiotemporal big data store.

Just a few ideas -


New Contributor III

After "Restarting the ArcGIS Data Store service fixed their issue.", restarting GeoEvent service will do the job as well.

0 Kudos
Esri Contributor

did you also register the Big Data Store in the Data Stores tab in GeoEvent Manager?

I had setup GeoEvent and Data Store with Portal and Server on my laptop and with some useful info from RJ I enabled the spatiotemporal big data store using that same command line. then registered the new datastore (as a portal store) in GeoEvent Manager. voila!


New Contributor II

Worked for me - thanks!


0 Kudos
Occasional Contributor


Thanks for the responses.  I have been getting quite a lot of errors in the logs relating to https/ssl issues.  I think that I need to sort these out before the functionality will work correctly.  Do you have a simple run down/best practice on where certificates need to be generated/signed/exported/imported?  I find the documentation a bit confusing.  I have an AD CA available in my test environment.

0 Kudos
New Contributor II


I had similar problems when building an all-in-one development VM.

You're right to address the SSL issues first to ensure you're not getting any requests rejected due to certificate issues. For an all-in-one I use the following approach:

1. In IIS either create a Self Signed Certificate or a Domain Certificate (see Create a Domain Server Certificate in IIS 7 on TechNet) and then use this to create SSL bindings on your default site.

2. Export this certificate from IIS to your desktop.

3. If it's a self-signed certificate then install it on the local machine into the 'Trusted Root Certificate Authorities'

4. Copy the certificate to any machine that will access the Dev system and install as per Step 3.

5. Open the ArcGIS Server Rest Admin and navigate to the machine and navigate to 'home > machines > machineName > sslcertificates > importExistingServerCertificate' to install the certificate saved to your desktop in 3.

6. Step back in the crumb trail to the machine and edit the machine properties.  Update the SSL certificate to the certificate imported above. This then ensures that the AGS internal web server is using the same certificate as IIS and will be recognised by your client(s).

7. Switch to the Portal for ArcGIS admin page (https://<server>/<webadaptername>/portaladmin) login using a Portal Administrator's credentials and select Security > SSL Certificates. Repeat the import Existing Server Certificate as performed in step 5.

8. Once imported, use the 'update' operation to update the Portal web server to use the certificate you've just imported.

9. Perhaps a bit of overkill, but I prefer to now restart the VM to ensure that the services come back up with the right certificates.

With a domain certificate you may need to check to ensure that the CA's root certificate has been installed into your Trusted Root CA store to ensure that your domain certificate can be validated.

I'd done all this and had the error you originally highlighted.  I found that Martin's pointer to add the Portal instance as a data store then solved my problems. (Thanks Martin!)


Occasional Contributor

RJ SundermanMarten HogewegAnthony Colby

Thanks heaps for your advice.  Following Anthony's advice on setting up the SSL certificates and then RJ and Marten's adive on setting the portal in data store worked great.  Everything worked much better.  Am I correct in guessing that if I was to split the install across several machines that the root certificate and server certificates would need to be installed into each machine?  So if there was a web server with the two web adapters, a portal machine, a server machine with GEE and two data store servers, one configured as BDS then the same steps should be taken to import the certificates into each one.  Do you need to create any extra certificates for the other machines?

Thanks again.

0 Kudos
Esri Regular Contributor

I'm not an SSL certificates guru, but I believe that you will want to export a domain certificate from your CA (I do this from within IIS) and then import that certificate into both Portal and Server. Do this on the machine that is providing your "WebGIS" ... the machine on which you're running Portal, the hosting Server, and the hosting Server's managed geodatabase (presumably the PostGRE RDBMS provided by ArcGIS Data Store).

Then, on the machine that is providing your "WebGIS", from a browser (I do this from witin Internet Explorer) you'll want to export a *.cer certificate. You'll then want to import that certificate into Server on machine you have set-up for "RealTime" event processing. Typically this second server has only ArcGIS Server and GeoEvent installed. You could choose to federate this second server with Portal - but you do not have to.

The reason, I've been told, that you want to export a *.cer from a browser and not from IIS is that a certificate generated by IIS will have the "WebGIS" server's private key ... which you do not want to share with other server mahcines. The browser generated certificate does not include the "WebGIS" server's private key, but will still allow GeoEvent (which will trust, by default, anything that the Server installation it is running under trusts) trust with Portal running on the other server machine.

This will probably be more clearly presented in a tutorial introducing the spatiotemporal big data store we are working to put up on the GeoEvent Gallery ASAP. The tutorial will not cover product installation and set-up of your WebGIS but will include some discussion on SSL certificates and the trust required between machines when configuring a server for your "WebGIS", a separate server for "RealTime", and a third server for hosting the BDS.

- RJ

0 Kudos
Occasional Contributor II

Hi RJ,

is the tutorial regarding SSL configuration you mentioned in your previous post already available?



0 Kudos