Problem upgrading from 10.2.0 to 10.2.2: adapter says "Invalid stream configuration"

3690
6
06-20-2014 02:39 AM
Highlighted
New Contributor
I have created a custom adapter for reading AIS data in Denmark, the source code is available on GitHub: https://github.com/pilsna/ais-for-geoevent.
The adapter is implemented for GeoEvent 10.2.0 and I've been running it successfully for a couple of months.
This week I've been trying to install it on a 10.2.2 server, and I receive the following error:
com.esri.ges.rest.stream.internal.OutputRestAdminServiceImpl
Invalid stream configuration: stream name is required.
Fri Jun 20 10:13:33 UTC 2014
ERROR

I can create a connector using the AIS adapter, the error appears when I try to add a new Input. Screenshot:
[ATTACH=CONFIG]34760[/ATTACH]
I've tried to raise the log level, with no success.

What can I do to dig deeper and find the cause of this error?

/Nils
Reply
0 Kudos
6 Replies
Highlighted
Esri Regular Contributor
Nils -

I apologize that we have not been able to respond to your forum post before now.

I have reached out to a couple of specific developers on the team for help since your issue appears to be more related to custom adapter development than general product usage. Someone will get back with you as soon as possible.

Thank you for your patience -
RJ
Reply
0 Kudos
Highlighted
New Contributor


I have reached out to a couple of specific developers on the team for help since your issue appears to be more related to custom adapter development than general product usage. Someone will get back with you as soon as possible.


Thanks for the reply RJ, I'll be waiting for some more feedback.

/Nils
Reply
0 Kudos
Highlighted
New Contributor III
The issue you encountered is most likely caused by the domain you used for the custom adapter.  com.esri.ges... is reserved for core components.  GEP will look for these components with the version that is the same of the GEP.  For example, if you are running 10.2.2 version of GEP, it will look for the text adapter of 10.2.2 when you try to create an input.  For custom adapters/transports/processors, you should use domain that does not start with com.esri.ges.  As a result, GEP will not try to find the version of this component that is identical to the GEP.  It will use whatever version the component claims to be.

Let us know if changing the domain fixes this problem.

Thanks,

Ming Zhao
Reply
0 Kudos
Highlighted
New Contributor III
Another thing I want to add is that after you recompiled the component with the correct domain and re-imported it into GEP or re-dropped it into the deploy folder, you need to remove the old connector and create a new connector.  The old connector has the incorrect version number for your custom components because its previous domain made it believe it was a core component.
Reply
0 Kudos
Highlighted
New Contributor
Hi Ming,

I changed the domain in the aisinbound-adapter-definition.xml file. This solved the problem. I can now create the input as usual.
Thanks a lot for the help!

/Nils

https://github.com/pilsna/ais-for-geoevent
Reply
0 Kudos
Highlighted
New Contributor III

Nils,

Do you have a version of this for version 10.3.1?

Reply
0 Kudos